summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-06-20 14:46:37 +0300
committerArtem Vorotnikov2015-06-20 14:46:37 +0300
commit0d12054b4bbdcc965d84073b4a727285a1aeaded (patch)
tree8996276507a1b0f1b9a2dc9c859cf970474f6ffe
downloadaur-0d12054b4bbdcc965d84073b4a727285a1aeaded.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db98f051adb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gtksourceview-highlight-rhtml
+ pkgdesc = Embedded Ruby syntax highlighting for gtksourceview
+ pkgver = LATEST
+ pkgrel = 1
+ url = https://github.com/gmate
+ arch = any
+ license = GPL
+ source = https://github.com/gmate/gmate/raw/master/lang-specs/rhtml.lang
+ sha512sums = SKIP
+
+pkgname = gtksourceview2-highlight-rhtml
+ depends = gtksourceview2
+ depends = gtksourceview2-highlight-rails
+
+pkgname = gtksourceview3-highlight-rhtml
+ depends = gtksourceview3
+ depends = gtksourceview3-highlight-rails
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9dd3a1cc7bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgbase=gtksourceview-highlight-rhtml
+pkgname=('gtksourceview2-highlight-rhtml' 'gtksourceview3-highlight-rhtml')
+pkgver=LATEST
+pkgrel=1
+pkgdesc='Embedded Ruby syntax highlighting for gtksourceview'
+arch=('any')
+url=('https://github.com/gmate')
+license=('GPL')
+source=('https://github.com/gmate/gmate/raw/master/lang-specs/rhtml.lang')
+sha512sums=('SKIP')
+
+package_gtksourceview2-highlight-rhtml() {
+ depends=('gtksourceview2' 'gtksourceview2-highlight-rails')
+
+ install -m644 -D rhtml.lang "$pkgdir/usr/share/gtksourceview-2.0/language-specs/rhtml.lang"
+}
+
+package_gtksourceview3-highlight-rhtml() {
+ depends=('gtksourceview3' 'gtksourceview3-highlight-rails')
+
+ install -m644 -D rhtml.lang "$pkgdir/usr/share/gtksourceview-3.0/language-specs/rhtml.lang"
+}
+