summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-09-08 05:01:06 +0300
committerArtem Vorotnikov2015-09-08 05:01:06 +0300
commitc26ec1a0c4a8d78f467b2e939a1b253e32dada13 (patch)
tree18c5d3f86d6c37266b64fe6c0062432ceb7076b0
downloadaur-c26ec1a0c4a8d78f467b2e939a1b253e32dada13.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02755bdc4797
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gtksourceview-highlight-toml
+ pkgdesc = TOML syntax highlighting for gtksourceview
+ pkgver = r8.8f3dd72
+ pkgrel = 1
+ url = https://github.com/liv-dumea/toml.lang
+ arch = any
+ license = GPL
+ source = git+https://github.com/liv-dumea/toml.lang.git
+ sha512sums = SKIP
+
+pkgname = gtksourceview2-highlight-toml
+ depends = gtksourceview2
+
+pkgname = gtksourceview3-highlight-toml
+ depends = gtksourceview3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28d48d3d292f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_reponame='toml.lang'
+pkgbase=gtksourceview-highlight-toml
+pkgname=('gtksourceview2-highlight-toml' 'gtksourceview3-highlight-toml')
+pkgver=r8.8f3dd72
+pkgrel=1
+pkgdesc='TOML syntax highlighting for gtksourceview'
+arch=('any')
+url=('https://github.com/liv-dumea/toml.lang')
+license=('GPL')
+source=('git+https://github.com/liv-dumea/toml.lang.git')
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$_reponame"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_gtksourceview2-highlight-toml() {
+ depends=('gtksourceview2')
+
+ install -Dm644 $srcdir/$_reponame/toml.lang "$pkgdir/usr/share/gtksourceview-2.0/language-specs/toml.lang"
+}
+
+package_gtksourceview3-highlight-toml() {
+ depends=('gtksourceview3')
+
+ install -Dm644 $srcdir/$_reponame/toml.lang "$pkgdir/usr/share/gtksourceview-3.0/language-specs/toml.lang"
+}
+