summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-05-15 12:56:38 +0200
committerPhilip Goto2021-05-15 12:56:38 +0200
commiteaddc3c0f48c32dfedac420bb52004eecdc310b1 (patch)
tree6d3db8f4e7326427cef6a3e7c93176c89213e409
parentd52a58968e8225710ecba7f77bd277a3fc2cdba5 (diff)
downloadaur-eaddc3c0f48c32dfedac420bb52004eecdc310b1.tar.gz
Re-add gtk-doc compilation as this magically works again
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1e4c64bc2fd..4c5bb9087aae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = gtksourceview5
pkgdesc = A text widget adding syntax highlighting and more to GNOME
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.gnome.org/GNOME/gtksourceview
arch = x86_64
arch = aarch64
license = LGPL
checkdepends = xorg-server-xvfb
- makedepends = git
makedepends = gobject-introspection
+ makedepends = gtk-doc
makedepends = meson
makedepends = vala
depends = gtk4
- source = git+https://gitlab.gnome.org/GNOME/gtksourceview.git#tag=5.0.0
+ source = https://gitlab.gnome.org/GNOME/gtksourceview/-/archive/5.0.0/gtksourceview-5.0.0.tar.gz
sha256sums = SKIP
pkgname = gtksourceview5
diff --git a/PKGBUILD b/PKGBUILD
index 232a10b8aa47..b9efdc7ec484 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@
pkgname=gtksourceview5
pkgver=5.0.0
-pkgrel=2
-pkgdesc="A text widget adding syntax highlighting and more to GNOME"
-url="https://gitlab.gnome.org/GNOME/gtksourceview"
-license=("LGPL")
+pkgrel=3
+pkgdesc='A text widget adding syntax highlighting and more to GNOME'
+url='https://gitlab.gnome.org/GNOME/gtksourceview'
+license=('LGPL')
arch=(x86_64 aarch64)
depends=(gtk4)
makedepends=(
- git
gobject-introspection
-# gtk-doc
+ gtk-doc
meson
vala
)
checkdepends=(xorg-server-xvfb)
-source=("git+https://gitlab.gnome.org/GNOME/gtksourceview.git#tag=${pkgver}")
+source=("${url}/-/archive/${pkgver}/gtksourceview-${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {
- arch-meson gtksourceview build # -D gtk_doc=true
+ arch-meson gtksourceview-${pkgver} build -D gtk_doc=true
meson compile -C build
}