summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Wu2019-02-02 22:20:47 +0800
committerDarren Wu2019-02-02 22:20:47 +0800
commit90049dc504ac12968c0c99c58ebbf44156cbfd5c (patch)
tree5b2fa8401b18f3c3a9be35be2f6dab726f54e3a6
downloadaur-90049dc504ac12968c0c99c58ebbf44156cbfd5c.tar.gz
release
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD93
-rw-r--r--gtkwave.install7
3 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aca39244d307
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = gtkwave-gtk3-tcl
+ pkgdesc = A wave viewer which reads LXT, LXT2, VZT, GHW, FST and VCD/EVCD files (GTK+ 3 version, with Tcl/Tk support)
+ pkgver = 3.3.98
+ pkgrel = 1
+ url = http://gtkwave.sourceforge.net
+ install = gtkwave.install
+ arch = x86_64
+ license = GPL
+ license = custom:MIT
+ license = custom
+ makedepends = gperf
+ depends = bzip2
+ depends = dconf
+ depends = desktop-file-utils
+ depends = glib2
+ depends = gnutls
+ depends = gtk3
+ depends = judy
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = libtiff
+ depends = tcl
+ depends = tk
+ depends = xz
+ provides = gtkwave
+ conflicts = gtkwave
+ source = http://gtkwave.sourceforge.net/gtkwave-gtk3-3.3.98.tar.gz
+ source = http://gtkwave.sourceforge.net/gtkwave.pdf
+ source = gtkwave.install
+ md5sums = b049a1633fd7db73f2bb907090e52b41
+ md5sums = 0f2af8e45fd4173c93eb24d0caa69498
+ md5sums = ccbede6bf65569f5688f5254389eec53
+
+pkgname = gtkwave-gtk3-tcl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd8be8f2ba22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: Darren Wu <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
+# Thanks: Jared Casper <jaredcasper@gmail.com>
+# Thanks: Kyle Keen <keenerd@gmail.com>
+# Thanks: Markus Koch <CClassicVideos@aol.com>
+# Thanks: Thomas Dziedzic < gostrc at gmail >
+
+pkgname=gtkwave-gtk3-tcl
+pkgver=3.3.98
+pkgrel=1
+pkgdesc='A wave viewer which reads LXT, LXT2, VZT, GHW, FST and VCD/EVCD files (GTK+ 3 version, with Tcl/Tk support)'
+arch=('x86_64')
+url='http://gtkwave.sourceforge.net'
+license=('GPL' 'custom:MIT' 'custom')
+depends=(
+ 'bzip2'
+ 'dconf' # gsettings
+ 'desktop-file-utils'
+ # 'gcc' # -lgnu-intl
+ # 'gconf'
+ # 'gcr' # -lgck
+ # 'gimp'
+ 'glib2' # -lgobject -lgthread gsettings
+ 'gnutls' #
+ 'gtk3'
+ 'judy' # --enable-judy
+ 'libjpeg-turbo' # -ljpeg
+ 'libpng' # -lpng
+ 'libtiff' # -ltiff
+ 'tcl'
+ 'tk'
+ 'xz' # liblzma
+)
+makedepends=('gperf')
+provides=('gtkwave')
+conflicts=('gtkwave')
+install='gtkwave.install'
+source=("http://gtkwave.sourceforge.net/${pkgname%-tcl}-${pkgver}.tar.gz"
+ "http://gtkwave.sourceforge.net/${pkgname%%-*}.pdf"
+ "gtkwave.install")
+
+md5sums=('b049a1633fd7db73f2bb907090e52b41'
+ '0f2af8e45fd4173c93eb24d0caa69498'
+ 'ccbede6bf65569f5688f5254389eec53')
+
+build() {
+ cd "$srcdir/${pkgname%-tcl}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ \
+ --disable-mime-update \
+ --enable-struct-pack \
+ --enable-manymarkers \
+ --disable-dependency-tracking \
+ --enable-xz \
+ --enable-fasttree \
+ --enable-judy \
+ --enable-schemas-compile \
+ --enable-largefile \
+ --enable-tcl \
+ --enable-tk \
+ --enable-gtk3 \
+ \
+ --with-gsettings \
+ --with-tcl=/usr/lib \
+ --with-tk=/usr/lib \
+
+ # --with-tcl=/usr/lib/tclConfig.sh \
+ # --with-tk=/usr/lib/tkConfig.sh \
+
+ # --with-gconf \
+ # --with-tcl=/usr/lib/tcl8.6 \
+ # --with-tk=/usr/lib/tk8.6 \
+ # --with-xdgdatadir=path \
+
+ make CFLAGS="-D_LARGEFILE64_SOURCE -O"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-tcl}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install-strip
+
+ mkdir -p "$pkgdir/usr/share/licenses/gtkwave"
+ install -D -m644 LICENSE.TXT \
+ "$pkgdir/usr/share/licenses/gtkwave/LICENSE.TXT"
+
+ mkdir -p "$pkgdir/usr/share/doc/gtkwave"
+ install -D -m644 "$srcdir/gtkwave.pdf" \
+ "$pkgdir/usr/share/doc/gtkwave/gtkwave.pdf"
+}
+
diff --git a/gtkwave.install b/gtkwave.install
new file mode 100644
index 000000000000..ba8586fa129d
--- /dev/null
+++ b/gtkwave.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo 'Make sure you copy the /usr/share/gtkwave/examples/gtkwaverc file to'
+ echo 'your home directory (as .gtkwaverc) or to your VCD project directory.'
+ echo 'It contains the prefs for a good configuration that most people find'
+ echo 'ergonomic. It is not strictly necessary however.'
+}
+