summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael DeGuzis2017-05-17 22:25:49 -0400
committerMichael DeGuzis2017-05-17 22:25:49 -0400
commit3324bc0eac45e244b40520413414dd22e9e1bae3 (patch)
treeed51aacfd0d40392d33a1157aab8d4d0678695fe
downloadaur-3324bc0eac45e244b40520413414dd22e9e1bae3.tar.gz
inital push
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD46
-rw-r--r--guacamole-client.install5
-rw-r--r--guacamole.properties3
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e20a6c711471
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = guacamole-client-git
+ pkgdesc = Java and Maven components of Guacamole
+ pkgver = 0.9.12.incubating.r89.g1c197ae4
+ pkgrel = 1
+ url = http://guacamole.sourceforge.net/
+ install = guacamole-client.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = maven
+ depends = java-runtime
+ depends = tomcat7
+ provides = guacamole
+ conflicts = guacamole-git
+ backup = usr/share/tomcat7/.guacamole/guacamole.properties
+ backup = usr/share/tomcat7/.guacamole/user-mapping.xml
+ source = guacamole-client::git+https://github.com/apache/incubator-guacamole-client
+ source = guacamole.properties
+ md5sums = SKIP
+ md5sums = 1f3ec0a32cc3c6b4f7aeb8a3b2e7531b
+
+pkgname = guacamole-client-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5644f894615
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Michael DeGuzis
+
+pkgname=guacamole-client-git
+_gitname=guacamole-client
+pkgver=0.9.12.incubating.r89.g1c197ae4
+pkgrel=1
+pkgdesc="Java and Maven components of Guacamole"
+arch=('any')
+url="http://guacamole.sourceforge.net/"
+license=('GPL3')
+conflicts=('guacamole-git')
+provides=('guacamole')
+depends=('java-runtime' 'tomcat7')
+makedepends=('git' 'maven')
+source=(
+ "$_gitname::git+https://github.com/apache/incubator-guacamole-client"
+ 'guacamole.properties'
+ )
+install=guacamole-client.install
+
+md5sums=(
+ 'SKIP'
+ '1f3ec0a32cc3c6b4f7aeb8a3b2e7531b'
+ )
+
+backup=('usr/share/tomcat7/.guacamole/guacamole.properties' 'usr/share/tomcat7/.guacamole/user-mapping.xml')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir"/$_gitname
+ mvn package
+}
+
+package() {
+ cd "$srcdir"/$_gitname
+ mkdir -m 775 -p "$pkgdir"/var/lib/tomcat7/
+ mkdir -m 775 -p "$pkgdir"/var/lib/tomcat7/webapps/
+ mkdir -p "$pkgdir"/usr/share/tomcat7/.${_gitname%-*}/
+ install -D ${_gitname%-*}/target/${_gitname%-*}-*-incubating.war "$pkgdir"/var/lib/tomcat7/webapps/guacamole-incubating.war
+ install -D ${_gitname%-*}/doc/example/user-mapping.xml "$pkgdir"/usr/share/tomcat7/.guacamole/
+ install -D "$srcdir"/guacamole.properties "$pkgdir"/usr/share/tomcat7/.guacamole/
+}
diff --git a/guacamole-client.install b/guacamole-client.install
new file mode 100644
index 000000000000..61c5d6308b38
--- /dev/null
+++ b/guacamole-client.install
@@ -0,0 +1,5 @@
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ echo -e "\n Attention. Since version 0.9.10, webapp changed to guacamole-incubating\n Change your URI accordingly.\n"
+}
diff --git a/guacamole.properties b/guacamole.properties
new file mode 100644
index 000000000000..4cba4b268a8f
--- /dev/null
+++ b/guacamole.properties
@@ -0,0 +1,3 @@
+guacd-hostname: localhost
+guacd-port: 4822
+