summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFigue2017-10-15 21:12:03 +0200
committerFigue2017-10-15 21:12:03 +0200
commit2b66ec077715a082a61afe58f4b0bf5772882fc3 (patch)
treea89c3a8ab86b08a6a2390e1a1ae8e6a79e8d3398
parentcb4755affc7d1cb5a3cd8994f3870dbee27ba75b (diff)
downloadaur-2b66ec077715a082a61afe58f4b0bf5772882fc3.tar.gz
Added a note and optdepends to let know that at least 1 monospace font is required to make console work
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--guacamole-server.install22
3 files changed, 26 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c1d424e3f74..ea3f5657cb6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = guacamole-server
pkgver = 0.9.13
pkgrel = 1
url = http://guacamole.sourceforge.net/
+ install = guacamole-server.install
arch = i686
arch = x86_64
arch = armv7h
@@ -24,6 +25,7 @@ pkgbase = guacamole-server
optdepends = freerdp: for rdp protocol support
optdepends = libpulse: for pulseaudio support
optdepends = libtelnet: for telnet protocol support
+ optdepends = monospace: any monospace font such as terminus-font, ttf-inconsolata or ttf-fira-mono. Without it, SSH will not work
replaces = guacd
replaces = libguac
replaces = libguac-client-ssh
diff --git a/PKGBUILD b/PKGBUILD
index fd5fbbb68d54..39b3ee7bf9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,9 @@ optdepends=('libssh: for ssh protocol support'
'freerdp: for rdp protocol support'
'libpulse: for pulseaudio support'
'libtelnet: for telnet protocol support'
+'monospace: any monospace font such as terminus-font, ttf-inconsolata or ttf-fira-mono. Without it, SSH will not work'
)
+install=$pkgname.install
source=("http://downloads.sourceforge.net/project/guacamole/current/source/$pkgname-$pkgver-incubating.tar.gz" 'guacd.service')
diff --git a/guacamole-server.install b/guacamole-server.install
new file mode 100644
index 000000000000..fde9d5c58622
--- /dev/null
+++ b/guacamole-server.install
@@ -0,0 +1,22 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "You need to have, at least, 1 monospace font installed in your system. Check optdepends to see some examples."
+}
+
+post_upgrade() {
+ post_install
+}
+