summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-12-04 22:43:11 +0100
committerJoan Figueras2022-12-04 22:43:11 +0100
commit6e5a7d7bac9a34e6b24433b16f95dd086d903436 (patch)
tree44752c20f2c6490221070d07e99038e20f896997
parentc791952c2495d4133d42e126ae65505b20c0b531 (diff)
downloadaur-6e5a7d7bac9a.tar.gz
Fixed SSL warnings
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1e899b6f013..0ce99e90014d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guacamole-server
pkgdesc = Guacamole proxy daemon
pkgver = 1.4.0
- pkgrel = 3
+ pkgrel = 4
url = http://guacamole.sourceforge.net/
install = guacamole-server.install
arch = i686
@@ -36,8 +36,12 @@ pkgbase = guacamole-server
source = http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/1.4.0/source/guacamole-server-1.4.0.tar.gz
source = guacd.conf
source = https://github.com/apache/guacamole-server/commit/bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a.patch
+ source = https://github.com/apache/guacamole-server/commit/9c93337d9781d4d85d84d9442297a2013c492837.patch
+ source = https://github.com/apache/guacamole-server/commit/f84db7d166fb76f33b879ae297a1899a12b80b57.patch
md5sums = b17c6152e96af0488ca4c0608e5ec3ae
md5sums = ab0ac97ad76d16be73768f89abb6ee7e
md5sums = bd58fffb01f7f6ab9bae306bdbea61ea
+ md5sums = 5010a8a2982c4ce5453c5a5c8d0a6845
+ md5sums = 6f9cfb4adce7628b7b5c1dc747934946
pkgname = guacamole-server
diff --git a/PKGBUILD b/PKGBUILD
index 35e1f3b4adae..eb774f1ad801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=guacamole-server
pkgver=1.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64' 'armv7h')
url="http://guacamole.sourceforge.net/"
@@ -23,24 +23,33 @@ install=$pkgname.install
source=("http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/${pkgver}/source/${pkgname}-${pkgver}.tar.gz"
"guacd.conf"
- "https://github.com/apache/guacamole-server/commit/bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a.patch")
+ "https://github.com/apache/guacamole-server/commit/bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a.patch"
+ "https://github.com/apache/guacamole-server/commit/9c93337d9781d4d85d84d9442297a2013c492837.patch"
+ "https://github.com/apache/guacamole-server/commit/f84db7d166fb76f33b879ae297a1899a12b80b57.patch")
backup=('etc/guacamole/guacd.conf')
md5sums=('b17c6152e96af0488ca4c0608e5ec3ae'
'ab0ac97ad76d16be73768f89abb6ee7e'
- 'bd58fffb01f7f6ab9bae306bdbea61ea')
+ 'bd58fffb01f7f6ab9bae306bdbea61ea'
+ '5010a8a2982c4ce5453c5a5c8d0a6845'
+ '6f9cfb4adce7628b7b5c1dc747934946')
prepare() {
cd "$srcdir"/$pkgname-$pkgver
# guacenc doesn't work since ffmpeg 4.4 (av_init_packet() is deprecated) so, we apply this patch
# Reference: https://github.com/apache/guacamole-server/pull/352/commits/bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a
patch -Np1 -i ../bc6b5cef25cb2c66cb4e0e96df6d2639a61a197a.patch
+
+ # Fix OpenSSL warnings
+ patch -Np1 -i ../9c93337d9781d4d85d84d9442297a2013c492837.patch
+ patch -Np1 -i ../f84db7d166fb76f33b879ae297a1899a12b80b57.patch
}
build() {
cd "$srcdir"/$pkgname-$pkgver
export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+ #./configure --prefix=/usr --sbindir=/usr/bin --with-systemd-dir=/usr/lib/systemd/system CPPFLAGS="-Wno-error=pedantic -Wno-error=deprecated-declarations"
./configure --prefix=/usr --sbindir=/usr/bin --with-systemd-dir=/usr/lib/systemd/system CPPFLAGS="-Wno-error=pedantic"
make
}