summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2019-01-18 00:23:19 +0100
committerJoan Figueras2019-01-18 00:23:19 +0100
commitc5015adf16e3d3c3b0d303d61e668f8ce20c615f (patch)
tree88515e1ee136e33c1c6921f2e87d09cdf7bb1044
parent31d41e42a9b8ca3ccbadb60a06f224615b63a77f (diff)
downloadaur-c5015adf16e3d3c3b0d303d61e668f8ce20c615f.tar.gz
Remove some things unnecessary
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--guacd.service13
3 files changed, 10 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 565b787dbdb3..efaa3d1a14d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guacamole-server
pkgdesc = Guacamole proxy daemon
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://guacamole.sourceforge.net/
install = guacamole-server.install
arch = i686
@@ -32,10 +32,8 @@ pkgbase = guacamole-server
replaces = libguac-client-vnc
replaces = libguac-client-rdp
source = http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/1.0.0/source/guacamole-server-1.0.0.tar.gz
- source = guacd.service
source = libavcodec.patch
md5sums = dc4a7775d8b676fa23c06e811d7a536d
- md5sums = dfaa29349d2e73af6dac75d6cafbd762
md5sums = 6cf58f3148d0ea3f24b4fa362ca79807
pkgname = guacamole-server
diff --git a/PKGBUILD b/PKGBUILD
index fa6f26bdc074..a71cada9b06f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=guacamole-server
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64' 'armv7h')
url="http://guacamole.sourceforge.net/"
@@ -21,25 +21,26 @@ optdepends=('libssh: for ssh protocol support'
install=$pkgname.install
source=("http://apache.org/dyn/closer.cgi?action=download&filename=guacamole/${pkgver}/source/${pkgname}-${pkgver}.tar.gz"
- 'guacd.service' libavcodec.patch)
+ libavcodec.patch)
md5sums=('dc4a7775d8b676fa23c06e811d7a536d'
- 'dfaa29349d2e73af6dac75d6cafbd762'
'6cf58f3148d0ea3f24b4fa362ca79807')
-
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i ../libavcodec.patch
+}
+
build() {
cd "$srcdir"/$pkgname-$pkgver
- patch -Np1 -i ../libavcodec.patch
#PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
#CFLAGS+=" -I/usr/include/openssl-1.0" \
#LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
- ./configure --prefix=/usr --sbindir=/usr/bin CPPFLAGS="-Wno-error=pedantic -Wno-error=format-overflow" ## Wno-error=format-overflow added to workaround build in GCC 7.1.1
+ ./configure --prefix=/usr --sbindir=/usr/bin --with-systemd-dir=/usr/lib/systemd/system CPPFLAGS="-Wno-error=pedantic"
make
}
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
- mkdir -p "$pkgdir"/usr/lib/systemd/system/
- install -Dm644 "$srcdir"/guacd.service "$pkgdir"/usr/lib/systemd/system/
}
diff --git a/guacd.service b/guacd.service
deleted file mode 100644
index adf99a9c55d4..000000000000
--- a/guacd.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=Guacamole Proxy Daemon
-After=network.target
-
-[Service]
-Type=forking
-PIDFile=/var/run/guacd.pid
-ExecStart=/usr/bin/guacd -p /var/run/guacd.pid
-Restart=on-failure
-
-[Install]
-WantedBy=multi-user.target
-