summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Talker2015-06-23 19:12:17 +0300
committerAlex Talker2015-06-23 19:12:17 +0300
commit50b09b3e39c4ac3724cc21cddb3fe65e41d5bb17 (patch)
tree375ea59e3a3e0fcabf6b91baa1fe5cc3fa2090f5
downloadaur-50b09b3e39c4ac3724cc21cddb3fe65e41d5bb17.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
-rw-r--r--dir.patch31
-rw-r--r--guake-colors-solarized-git.install12
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd31d88f6ded
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = guake-colors-solarized-git
+ pkgdesc = Precision colors for machines and people. Guake integration.
+ pkgver = 16
+ pkgrel = 1
+ url = http://ethanschoonover.com/solarized
+ install = guake-colors-solarized-git.install
+ arch = any
+ license = Custom, FOSS
+ makedepends = git
+ depends = guake
+ provides = guake-colors-solarized
+ conflicts = guake-colors-solarized
+ source = git+https://github.com/coolwanglu/guake-colors-solarized
+ source = dir.patch
+ md5sums = SKIP
+ md5sums = 1e0761637fe55ee8de1904440be3c1ec
+
+pkgname = guake-colors-solarized-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..497a4df568fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Agustin Ferrario 'py_crash' <agustin dot ferrario at hotmail dot com>
+
+pkgname=guake-colors-solarized-git
+pkgver=16
+pkgrel=1
+pkgdesc="Precision colors for machines and people. Guake integration."
+arch=('any')
+url="http://ethanschoonover.com/solarized"
+license=('Custom, FOSS')
+depends=('guake')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+install=$pkgname.install
+source=("git+https://github.com/coolwanglu/${pkgname%-*}"
+ "dir.patch")
+md5sums=('SKIP'
+ '1e0761637fe55ee8de1904440be3c1ec')
+
+pkgver() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ patch -p1 -i $srcdir/dir.patch
+
+}
+
+
+package() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ install -dm 755 "${pkgdir}"/usr/bin
+ install -m 755 {,"${pkgdir}"/usr/bin/}set_dark.sh
+ install -m 755 {,"${pkgdir}"/usr/bin/}set_light.sh
+
+ install -dm 755 "${pkgdir}"/usr/share/guake/solarized-colors
+ mv colors "${pkgdir}"/usr/share/guake/solarized-colors/
+
+ install -dm 755 "${pkgdir}"/usr/share/guake/solarized-colors/doc
+ install -m 644 {,"${pkgdir}"/usr/share/guake/solarized-colors/doc/}README.mkd
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m 644 {,"${pkgdir}"/usr/share/licenses/${pkgname}/}LICENSE.mkd
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/dir.patch b/dir.patch
new file mode 100644
index 000000000000..1d60c70867ba
--- /dev/null
+++ b/dir.patch
@@ -0,0 +1,31 @@
+commit 5d86b2ae19baf36bd94689bba1e6875d7feac5d5
+Author: Agustin Ferrario <agustin.ferrario@hotmail.com.ar>
+Date: Thu May 30 02:02:14 2013 -0300
+
+ Updated directories to the proper Arch directories
+
+diff --git a/set_dark.sh b/set_dark.sh
+index 5742e80..ad5a6a9 100755
+--- a/set_dark.sh
++++ b/set_dark.sh
+@@ -1,6 +1,6 @@
+ #!/usr/bin/env bash
+ default='solarized'
+-dir=`dirname $0`
++dir='/usr/share/guake/solarized-colors/'
+
+ if [ -d $dir/colors/$1 ]; then
+ theme=$1
+
+diff --git a/set_light.sh b/set_light.sh
+index e150376..7283c7b 100755
+--- a/set_light.sh
++++ b/set_light.sh
+@@ -1,6 +1,6 @@
+ #!/usr/bin/env bash
+ default='solarized'
+-dir=`dirname $0`
++dir='/usr/share/guake/solarized-colors/'
+
+ if [ -d $dir/colors/$1 ]; then
+ theme=$1
diff --git a/guake-colors-solarized-git.install b/guake-colors-solarized-git.install
new file mode 100644
index 000000000000..f66e60234cde
--- /dev/null
+++ b/guake-colors-solarized-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "=====> To use solarized colors run:"
+ echo "=====> $ set_dark.sh \#to use the dark version of solarized colors"
+ echo "=====> $ set_light.sh \#to use the light version of solarized colors"
+}
+
+
+post_upgrade() {
+ echo "=====> To use solarized colors run:"
+ echo "=====> $ set_dark.sh \#to use the dark version of solarized colors"
+ echo "=====> $ set_light.sh \#to use the light version of solarized colors"
+}