summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Angel Useche Castro2018-12-26 00:39:00 -0400
committerMiguel Angel Useche Castro2018-12-26 00:39:00 -0400
commit3345ff20e9d10c9aa05d061007b2567a47007fbb (patch)
treefcfb8051bb41495c50a2235becb1a0a35a15e4bb
parent8f66374d373c1daba02aef4c9733907d1d51c2a5 (diff)
downloadaur-3345ff20e9d10c9aa05d061007b2567a47007fbb.tar.gz
updating pkg to solve errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a108221c4927..c3258ed23c37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guake-git
pkgdesc = Top-down terminal for Gnome using gtk3 and vte3
- pkgver = 3.2.1.11.g284f9e9
- pkgrel = 2
+ pkgver = 3.4.0.37.gd2d351d
+ pkgrel = 1
url = https://github.com/Guake/guake
arch = i686
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = guake-git
depends = python-gobject
depends = gettext
depends = gobject-introspection-runtime
+ depends = libwnck3
provides = guake
conflicts = guake
conflicts = guake-gtk2-git
diff --git a/PKGBUILD b/PKGBUILD
index bbeb5c3e875a..707980ab7587 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
# Contributor: Anton Leontiev <unsector /at/ km.ru>
# Contributor: Sandy Carter <bwrsandman /at/ gmail.com>
# Contributor: Mario Aichinger <aichingm /at/ gmail.com>
+# Contributor: Florian Reimair <office /at/ florianreimair.at>
pkgname=guake-git
-pkgver=3.2.1.11.g284f9e9
-pkgrel=2
+pkgver=3.4.0.37.gd2d351d
+pkgrel=1
pkgdesc="Top-down terminal for Gnome using gtk3 and vte3"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/Guake/guake"
license=('GPL')
-depends=('vte3' 'gtk3' 'python-pbr' 'python-dbus' 'python-xdg' 'libutempter' 'libkeybinder3' 'python-cairo' 'vte-common' 'python-gobject' 'gettext' 'gobject-introspection-runtime')
+depends=('vte3' 'gtk3' 'python-pbr' 'python-dbus' 'python-xdg' 'libutempter' 'libkeybinder3' 'python-cairo' 'vte-common' 'python-gobject' 'gettext'
+'gobject-introspection-runtime' 'libwnck3')
makedepends=('git' 'python-pip' 'make')
conflicts=('guake' 'guake-gtk2-git')
provides=('guake')
@@ -29,5 +31,11 @@ build(){
package() {
cd "${srcdir}/${pkgname%-git}"
- make install DESTDIR="$pkgdir/" PREFIX="/usr" COMPILE_SCHEMA=0
+ make install DESTDIR="$pkgdir" PREFIX="/usr" COMPILE_SCHEMA=1
+ cd "${pkgdir}"
+ mv "usr/local/lib" "usr/"
}
+
+#post_install() {
+# glib-compile-schemas --strict /usr/local/share/glib-2.0/schemas
+#}