summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinicius Moreira2021-10-06 12:43:30 -0300
committerVinicius Moreira2021-10-06 12:43:30 -0300
commit1cb6fa60ec78df197ba1d895089ab7173c935ed0 (patch)
tree861037955dedba0d0aae376e7f594252caaa3722
downloadaur-1cb6fa60ec78df197ba1d895089ab7173c935ed0.tar.gz
1.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
-rwxr-xr-xupdatesrc.sh2
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db6b010b29dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = guapow
+ pkgdesc = On-demand and auto performance optimizer for Linux applications
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/vinifmor/guapow
+ arch = any
+ license = zlib/libpng
+ makedepends = git
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-aiofiles
+ depends = python-aiohttp
+ depends = python-pycryptodome
+ depends = systemd
+ optdepends = unclutter: required for hiding the mouse cursor
+ source = https://github.com/vinifmor/guapow/archive/1.0.0.tar.gz
+ sha512sums = 15de982783170155b81d4d173a9238e543d336f9f94aa06c17efab654a0bc9fc3f36166a2d3c27a119e2cc7f0d4c2f10a4d9bd7102523581b04c6a34811d531e
+
+pkgname = guapow
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef9d1a5f3caa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+*.zip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1473a5e0e77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vinícius Moreira <vinicius_fmoreira@hotmail.com>
+
+pkgname=guapow
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="On-demand and auto performance optimizer for Linux applications"
+arch=('any')
+url="https://github.com/vinifmor/guapow"
+license=('zlib/libpng')
+depends=('python' 'python-aiofiles' 'python-aiohttp' 'python-pycryptodome' 'systemd')
+optdepends=('unclutter: required for hiding the mouse cursor')
+makedepends=('git' 'python' 'python-setuptools')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha512sums=('15de982783170155b81d4d173a9238e543d336f9f94aa06c17efab654a0bc9fc3f36166a2d3c27a119e2cc7f0d4c2f10a4d9bd7102523581b04c6a34811d531e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python3 setup.py build
+ python3 setup.py test || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+
+ mkdir -p $pkgdir/etc/$pkgname
+ cp $pkgname/dist/daemon/opt.conf $pkgdir/etc/$pkgname/opt.conf.example
+ cp $pkgname/dist/daemon/watch.conf $pkgdir/etc/$pkgname/watch.conf.example
+ cp $pkgname/dist/default.profile $pkgdir/etc/$pkgname/default.profile.example
+
+ mkdir -p $pkgdir/usr/lib/systemd/system
+ cp $pkgname/dist/daemon/systemd/root/$pkgname-opt.service $pkgdir/usr/lib/systemd/system
+}
diff --git a/updatesrc.sh b/updatesrc.sh
new file mode 100755
index 000000000000..44279c59076b
--- /dev/null
+++ b/updatesrc.sh
@@ -0,0 +1,2 @@
+makepkg --printsrcinfo > .SRCINFO
+git add -f PKGBUILD .SRCINFO