summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Furry2015-11-12 08:28:40 -0700
committerScott Furry2015-11-12 08:28:40 -0700
commit062731f51a7f378c5968f49a7df07d8af652d19e (patch)
tree4fde70691121108dc1277abf3711dcbafddaaca9
parent5696d91a94c5e9d8cf2013e29a6c71c40265836d (diff)
downloadaur-062731f51a7f378c5968f49a7df07d8af652d19e.tar.gz
Correct player presentation for current playing track
Include overlooked patch correcting path to wxcurl header
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--README8
-rw-r--r--guayadeque_04_wxcurl.patch78
-rw-r--r--guayadeque_05_wxSqlite_upgrade.patch (renamed from guayadeque_04_wxSqlite_upgrade.patch)0
-rw-r--r--guayadeque_06_pixbuf_link.patch (renamed from guayadeque_05_pixbuf_link.patch)0
-rw-r--r--guayadeque_07_player_display_fix.patch70
7 files changed, 172 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e905b19a14d..f57bed681ef5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guayadeque
pkgdesc = Lightweight music player
pkgver = 0.3.7
- pkgrel = 3
+ pkgrel = 5
url = http://guayadeque.org/
install = guayadeque.install
arch = i686
@@ -25,8 +25,10 @@ pkgbase = guayadeque
source = guayadeque_01d_rev1894.patch
source = guayadeque_02_pause_crash.patch
source = guayadeque_03_wx30.patch
- source = guayadeque_04_wxSqlite_upgrade.patch
- source = guayadeque_05_pixbuf_link.patch
+ source = guayadeque_04_wxcurl.patch
+ source = guayadeque_05_wxSqlite_upgrade.patch
+ source = guayadeque_06_pixbuf_link.patch
+ source = guayadeque_07_player_display_fix.patch
sha256sums = d23eb1247add0bef8d5fef834294d7cb3d7c5fc20db9022b86f618a13d359938
sha256sums = 56ff5fae064fa421cb951a7c664550861e04ae4df8b692044e2a4785f238ce24
sha256sums = 15b49c58be40a57ecb1d38e7055c1edc5aaf71e0164062cc5f2b8fb589530377
@@ -34,8 +36,10 @@ pkgbase = guayadeque
sha256sums = b4101860ee371f3d37329267ff71efcb2f3b117399997209197687d1864c6716
sha256sums = b0a17d8a4b69e5559966d84f9a517e268198a62ccbb178db78a4772b52d62e8f
sha256sums = 52bc278567abbd88fc281cdbaa10427be2e28028cd8c307d58a718c061607f45
+ sha256sums = f6e8faedeac2ff47f6f2ea0ef3cb7737aafb9f7179b49313aac0f07b63783506
sha256sums = 6bd07e63afe0aa7baf30b616d701e234fd1c304897053e3eb466acb2db818071
sha256sums = 23d388711a17dc7e1487c740fd961ceb563a967d5866c5d5508865252be2d645
+ sha256sums = e2dbb71fc1d6118fa31d30f49382c16bb306130fc94118f3df9f0ea64c27ca0f
pkgname = guayadeque
diff --git a/PKGBUILD b/PKGBUILD
index 624564ae6887..4eb101a37517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=guayadeque
pkgver=0.3.7
-pkgrel=3
+pkgrel=5
pkgdesc='Lightweight music player'
arch=('i686' 'x86_64')
url='http://guayadeque.org/'
@@ -25,8 +25,10 @@ source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgve
'guayadeque_01d_rev1894.patch'
'guayadeque_02_pause_crash.patch'
'guayadeque_03_wx30.patch'
- 'guayadeque_04_wxSqlite_upgrade.patch'
- 'guayadeque_05_pixbuf_link.patch')
+ 'guayadeque_04_wxcurl.patch'
+ 'guayadeque_05_wxSqlite_upgrade.patch'
+ 'guayadeque_06_pixbuf_link.patch'
+ 'guayadeque_07_player_display_fix.patch')
sha256sums=('d23eb1247add0bef8d5fef834294d7cb3d7c5fc20db9022b86f618a13d359938'
'56ff5fae064fa421cb951a7c664550861e04ae4df8b692044e2a4785f238ce24'
'15b49c58be40a57ecb1d38e7055c1edc5aaf71e0164062cc5f2b8fb589530377'
@@ -34,8 +36,10 @@ sha256sums=('d23eb1247add0bef8d5fef834294d7cb3d7c5fc20db9022b86f618a13d359938'
'b4101860ee371f3d37329267ff71efcb2f3b117399997209197687d1864c6716'
'b0a17d8a4b69e5559966d84f9a517e268198a62ccbb178db78a4772b52d62e8f'
'52bc278567abbd88fc281cdbaa10427be2e28028cd8c307d58a718c061607f45'
+ 'f6e8faedeac2ff47f6f2ea0ef3cb7737aafb9f7179b49313aac0f07b63783506'
'6bd07e63afe0aa7baf30b616d701e234fd1c304897053e3eb466acb2db818071'
- '23d388711a17dc7e1487c740fd961ceb563a967d5866c5d5508865252be2d645')
+ '23d388711a17dc7e1487c740fd961ceb563a967d5866c5d5508865252be2d645'
+ 'e2dbb71fc1d6118fa31d30f49382c16bb306130fc94118f3df9f0ea64c27ca0f')
BUILDFLDR='buildlocal'
prepare() {
@@ -46,8 +50,10 @@ prepare() {
patch -Np0 -i ../guayadeque_01d_rev1894.patch
patch -Np0 -i ../guayadeque_02_pause_crash.patch
patch -Np0 -i ../guayadeque_03_wx30.patch
- patch -Np0 -i ../guayadeque_04_wxSqlite_upgrade.patch
- patch -Np0 -i ../guayadeque_05_pixbuf_link.patch
+ patch -Np0 -i ../guayadeque_04_wxcurl.patch
+ patch -Np0 -i ../guayadeque_05_wxSqlite_upgrade.patch
+ patch -Np0 -i ../guayadeque_06_pixbuf_link.patch
+ patch -Np0 -i ../guayadeque_07_player_display_fix.patch
}
build() {
diff --git a/README b/README
index cf482f90e6f0..a433d81815dd 100644
--- a/README
+++ b/README
@@ -4,7 +4,7 @@ http://guayadeque.org/
Thank you's to:
Alessio Treglia <alessio@debian.org> (Debian maintainer)
-Martin Gansser <mgansser@alice.de> (Fedora maintainer)
+Olly Betts <olly@survex.com> (Debian contributor)
Maxime Gauduin <alucryd@archlinux.org> (Arch maintainer)
for their work and efforts which lead to this package.
@@ -17,8 +17,10 @@ for their work and efforts which lead to this package.
guayadeque_01d_rev1894 (update to SVN rev 1894)
guayadeque_02_pause_crash.patch (correct crash on pause/stop track)
guayadeque_03_wx30.patch (update src for use with wx3.0)
- guayadeque_04_wxSqlite_upgrade.patch (update internal wxSqlite3 to rev 3.2.1)
- guayadeque_05_pixbuf_link.patch (add build link to libgdk-pixbuf-2.0.so)
+ guayadeque_04_wxcurl.patch (update header path for wxcurl)
+ guayadeque_05_wxSqlite_upgrade.patch (update internal wxSqlite3 to rev 3.2.1)
+ guayadeque_06_pixbuf_link.patch (add build link to libgdk-pixbuf-2.0.so)
+ guayadeque_07_player_display_fix.patch(correct current track display bug)
=====
KNOWN BUILD ISSUES
diff --git a/guayadeque_04_wxcurl.patch b/guayadeque_04_wxcurl.patch
new file mode 100644
index 000000000000..4ca29c21b15a
--- /dev/null
+++ b/guayadeque_04_wxcurl.patch
@@ -0,0 +1,78 @@
+diff --git src/LastFM.cpp src/LastFM.cpp
+index 14fdb90..12b0444 100644
+--- src/LastFM.cpp
++++ src/LastFM.cpp
+@@ -24,7 +24,7 @@
+ #include "DbCache.h"
+ #include "Utils.h"
+
+-#include "curl/http.h"
++#include "wx/curl/http.h"
+
+ #include <wx/arrimpl.cpp>
+ #include <wx/sstream.h>
+diff --git src/LastFMPanel.cpp src/LastFMPanel.cpp
+index 56d8edd..c2a3f28 100644
+--- src/LastFMPanel.cpp
++++ src/LastFMPanel.cpp
+@@ -21,7 +21,7 @@
+ #include "LastFMPanel.h"
+
+ #include "Commands.h"
+-#include "curl/http.h"
++#include "wx/curl/http.h"
+ #include "Images.h"
+ #include "MainApp.h"
+ #include "Settings.h"
+diff --git src/LyricsPanel.cpp src/LyricsPanel.cpp
+index 10a0660..7e03aab 100644
+--- src/LyricsPanel.cpp
++++ src/LyricsPanel.cpp
+@@ -23,7 +23,7 @@
+ #include "Base64.h"
+ #include "Commands.h"
+ #include "Config.h"
+-#include "curl/http.h"
++#include "wx/curl/http.h"
+ #include "Preferences.h"
+ #include "Images.h"
+ #include "ListView.h"
+diff --git src/MusicBrainz.cpp src/MusicBrainz.cpp
+index 9bdd48a..102f622 100644
+--- src/MusicBrainz.cpp
++++ src/MusicBrainz.cpp
+@@ -21,7 +21,7 @@
+ #include "MusicBrainz.h"
+
+ #include "Utils.h"
+-#include "curl/http.h"
++#include "wx/curl/http.h"
+
+ #include <wx/arrimpl.cpp>
+ #include <wx/sstream.h>
+diff --git src/MusicDns.cpp src/MusicDns.cpp
+index b211c64..6bdf115 100644
+--- src/MusicDns.cpp
++++ src/MusicDns.cpp
+@@ -21,7 +21,7 @@
+ #include "MusicDns.h"
+
+ #include "Commands.h"
+-#include "curl/http.h"
++#include "wx/curl/http.h"
+ #include "MusicBrainz.h"
+ #include "Utils.h"
+ #include "Version.h"
+diff --git src/Podcasts.h src/Podcasts.h
+index 6855483..0772ee1 100644
+--- src/Podcasts.h
++++ src/Podcasts.h
+@@ -21,7 +21,7 @@
+ #ifndef PODCASTS_H
+ #define PODCASTS_H
+
+-#include "curl/http.h"
++#include "wx/curl/http.h"
+
+ #include <wx/dynarray.h>
+ #include <wx/xml/xml.h>
diff --git a/guayadeque_04_wxSqlite_upgrade.patch b/guayadeque_05_wxSqlite_upgrade.patch
index a85f50048470..a85f50048470 100644
--- a/guayadeque_04_wxSqlite_upgrade.patch
+++ b/guayadeque_05_wxSqlite_upgrade.patch
diff --git a/guayadeque_05_pixbuf_link.patch b/guayadeque_06_pixbuf_link.patch
index 623ac9e15b80..623ac9e15b80 100644
--- a/guayadeque_05_pixbuf_link.patch
+++ b/guayadeque_06_pixbuf_link.patch
diff --git a/guayadeque_07_player_display_fix.patch b/guayadeque_07_player_display_fix.patch
new file mode 100644
index 000000000000..509b3a386a88
--- /dev/null
+++ b/guayadeque_07_player_display_fix.patch
@@ -0,0 +1,70 @@
+diff --git src/AutoScrollText.cpp src/AutoScrollText.cpp
+index 7be1b90..4652238 100644
+--- src/AutoScrollText.cpp
++++ src/AutoScrollText.cpp
+@@ -36,7 +36,7 @@ END_EVENT_TABLE()
+
+ // -------------------------------------------------------------------------------- //
+ guAutoScrollText::guAutoScrollText( wxWindow * parent, const wxString &label, const wxSize &size ) :
+- wxControl( parent, wxID_ANY )
++ wxControl( parent, wxID_ANY, wxDefaultPosition, size, wxBORDER_NONE )
+ {
+ m_ScrollPos = 0;
+ m_ScrollQuantum = 1;
+diff --git src/PlayerPanel.cpp src/PlayerPanel.cpp
+index 326314f..a81e55e 100644
+--- src/PlayerPanel.cpp
++++ src/PlayerPanel.cpp
+@@ -260,48 +260,40 @@ guPlayerPanel::guPlayerPanel( wxWindow * parent, guDbLibrary * db,
+ PlayerDetailsSizer = new wxBoxSizer( wxHORIZONTAL );
+
+ m_PlayerCoverBitmap = new wxStaticBitmap( this, wxID_ANY, guImage( guIMAGE_INDEX_no_cover ), wxDefaultPosition, wxSize( 100,100 ), 0 );
+- //m_PlayerCoverBitmap->SetToolTip( _( "Shows the current track album cover if available" ) );
+ PlayerDetailsSizer->Add( m_PlayerCoverBitmap, 0, wxALL, 2 );
+
+ wxBoxSizer* PlayerLabelsSizer;
+ PlayerLabelsSizer = new wxBoxSizer( wxVERTICAL );
+
+- //m_TitleLabel = new wxStaticText( this, wxID_ANY, wxEmptyString, wxDefaultPosition, wxDefaultSize, 0 );
+ m_TitleLabel = new guAutoScrollText( this, wxEmptyString );
+ m_TitleLabel->SetToolTip( _( "Show the name of the current track" ) );
+- //m_TitleLabel->Wrap( -1 );
+ CurrentFont.SetPointSize( guPLAYER_FONTSIZE_TRACKNAME );
+ CurrentFont.SetWeight( wxFONTWEIGHT_BOLD );
+ m_TitleLabel->SetFont( CurrentFont );
+
+- PlayerLabelsSizer->Add( m_TitleLabel, 0, wxEXPAND|wxLEFT|wxRIGHT|wxBOTTOM, 2 );
++ PlayerLabelsSizer->Add( m_TitleLabel, 1, wxEXPAND, 2 );
+
+- //m_AlbumLabel = new wxStaticText( this, wxID_ANY, wxEmptyString, wxDefaultPosition, wxDefaultSize, 0 );
+ m_AlbumLabel = new guAutoScrollText( this, wxEmptyString );
+ m_AlbumLabel->SetToolTip( _( "Show the album name of the current track" ) );
+- //m_AlbumLabel->Wrap( -1 );
+ CurrentFont.SetPointSize( guPLAYER_FONTSIZE_ALBUMNAME );
+ CurrentFont.SetWeight( wxFONTWEIGHT_NORMAL );
+ CurrentFont.SetStyle( wxFONTSTYLE_ITALIC );
+ m_AlbumLabel->SetFont( CurrentFont );
+
+- PlayerLabelsSizer->Add( m_AlbumLabel, 0, wxEXPAND|wxLEFT|wxRIGHT|wxBOTTOM, 2 );
++ PlayerLabelsSizer->Add( m_AlbumLabel, 1, wxEXPAND, 2 );
+
+- //m_ArtistLabel = new wxStaticText( this, wxID_ANY, wxEmptyString, wxDefaultPosition, wxDefaultSize, 0 );
+ m_ArtistLabel = new guAutoScrollText( this, wxEmptyString );
+ m_ArtistLabel->SetToolTip( _( "Show the artist name of the current track" ) );
+- //m_ArtistLabel->Wrap( -1 );
+ CurrentFont.SetPointSize( guPLAYER_FONTSIZE_ARTISTNAME );
+ CurrentFont.SetStyle( wxFONTSTYLE_NORMAL );
+ m_ArtistLabel->SetFont( CurrentFont );
+
+- PlayerLabelsSizer->Add( m_ArtistLabel, 0, wxEXPAND|wxLEFT|wxRIGHT|wxBOTTOM, 2 );
++ PlayerLabelsSizer->Add( m_ArtistLabel, 1, wxEXPAND, 2 );
+
+ m_PosLabelSizer = new wxBoxSizer( wxHORIZONTAL );
+- //m_PosLabelSizer->Add( 0, 0, 1, wxEXPAND, 5 );
+ m_YearLabel = new wxStaticText( this, wxID_ANY, wxEmptyString, wxDefaultPosition, wxDefaultSize, 0 );
+ m_YearLabel->SetToolTip( _( "Show the year of the current track" ) );
+- m_PosLabelSizer->Add( m_YearLabel, 1, wxALIGN_CENTER_VERTICAL|wxLEFT|wxRIGHT, 2 );
++ m_PosLabelSizer->Add( m_YearLabel, 1, wxALIGN_CENTER_VERTICAL, 2 );
+
+ m_PositionLabel = new wxStaticText( this, wxID_ANY, _("00:00 of 00:00"), wxDefaultPosition, wxDefaultSize, 0 );
+ m_PositionLabel->SetToolTip( _( "Show the current position and song length of the current track" ) );