summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-08-17 16:10:34 +0200
committerFabioLolix2020-08-17 16:10:34 +0200
commit5069ed1ec6ba05aa08535d1eb650920edbb3e148 (patch)
tree1707742a8a39a54ce13183f55d84348757145538
parentcbc37d56f4c19375a599590079c2556cfd553d67 (diff)
downloadaur-5069ed1ec6ba05aa08535d1eb650920edbb3e148.tar.gz
fix build issue
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--README47
3 files changed, 12 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d45a1c269d8..f091259d7fd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guayadeque
pkgdesc = Lightweight music player
pkgver = 0.4.6
- pkgrel = 1
+ pkgrel = 2
url = http://guayadeque.org/
arch = i686
arch = x86_64
@@ -17,7 +17,9 @@ pkgbase = guayadeque
optdepends = gst-plugins-bad: additional codecs
optdepends = gst-plugins-ugly: additional codecs
source = guayadeque-0.4.6.tar.gz::https://github.com/anonbeat/guayadeque/archive/v0.4.6.tar.gz
+ source = https://github.com/anonbeat/guayadeque/commit/6be35ba2153f1c36400b8c535d8ba49292a1f51e.diff
sha256sums = 3c0d782c6f4aa511c7a635a78742542d130d1a13e20648db886ccfce4e1b9d4f
+ sha256sums = ac536bb3aa23fedd7634b31dbb309c0e130c5bd1a3bfbbab096bcc897091363a
pkgname = guayadeque
diff --git a/PKGBUILD b/PKGBUILD
index 33e1d2952c4e..da279a5781c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Marcin (CTRL) Wieczorek <marcin@marcin.co>
# Contributor: Scott Furry <scott.wl.furry@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
@@ -8,7 +8,7 @@
pkgname=guayadeque
pkgver=0.4.6
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight music player"
arch=(i686 x86_64)
url="http://guayadeque.org/"
@@ -18,12 +18,15 @@ makedepends=(cmake)
optdepends=('gst-libav: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/anonbeat/guayadeque/archive/v${pkgver}.tar.gz")
-sha256sums=('3c0d782c6f4aa511c7a635a78742542d130d1a13e20648db886ccfce4e1b9d4f')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/anonbeat/guayadeque/archive/v${pkgver}.tar.gz"
+ "https://github.com/anonbeat/guayadeque/commit/6be35ba2153f1c36400b8c535d8ba49292a1f51e.diff")
+sha256sums=('3c0d782c6f4aa511c7a635a78742542d130d1a13e20648db886ccfce4e1b9d4f'
+ 'ac536bb3aa23fedd7634b31dbb309c0e130c5bd1a3bfbbab096bcc897091363a')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- mkdir -p build-guayadeque
+ install -d build-guayadeque
+ patch -Np1 -i ../6be35ba2153f1c36400b8c535d8ba49292a1f51e.diff
}
build() {
@@ -36,7 +39,7 @@ build() {
-DCMAKE_EXE_LINKER_FLAGS=-lwx_gtk3u_aui-3.0 \
-DwxWidgets_wxrc_EXECUTABLE=/usr/bin/wxrc-3.0 \
-DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
- -DwxWidgets_INCLUDE_DIRS=/usr/include/wx-3.0/
+ -DwxWidgets_INCLUDE_DIRS=/usr/include/wx-3.0
make
}
diff --git a/README b/README
deleted file mode 100644
index 88cd904c37d1..000000000000
--- a/README
+++ /dev/null
@@ -1,47 +0,0 @@
-Guayadeque Music Player
-Arch Linux packaging
-http://guayadeque.org/
-
-Thank you's to:
-Alessio Treglia <alessio@debian.org> (Debian maintainer)
-Olly Betts <olly@survex.com> (Debian contributor)
-Maxime Gauduin <alucryd@archlinux.org> (Arch maintainer)
-for their work and efforts which lead to this package.
-
-=== initial release
-- Start with latest Guayadeque Release(dated 2014-02-10)
-- Apply patches
- guayadeque_01a_rev1891 (update download to SVN rev 1891)
- guayadeque_01b_rev1892 (update to SVN rev 1892)
- guayadeque_01c_rev1893 (update to SVN rev 1893)
- guayadeque_01d_rev1894 (update to SVN rev 1894)
- guayadeque_02_pause_crash.patch (correct crash on pause/stop track)
- guayadeque_03_wx30.patch (update src for use with wx3.0)
- guayadeque_04_wxcurl.patch (update header path for wxcurl)
- guayadeque_05_wxSqlite_upgrade.patch (update internal wxSqlite3 to rev 3.2.1)
- guayadeque_06_pixbuf_link.patch (add build link to libgdk-pixbuf-2.0.so)
- guayadeque_07_player_display_fix.patch (correct current track display bug)
- guayadeque_08_EditCrash.patch (workaround seg error when editing track ID3)
- guayadeque_09_gstreamer_deprecated.patch (replace gstreamer deprecated pad call)
-
-=====
-KNOWN BUILD ISSUES
-=====
-"Wno-deprecated-declarations" is used to suppress overflowing cpp warnings
-when compiling against wxWidgets. A change in g++ to 5.1 has created this
-situation.
-
-gcc bug 65974 filed by wxWidgets maintainer:
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65974
-
-Build Warning:
-src/ListView.cpp:595:35: warning: comparison of constant ‘-1’ with boolean expression is always true [-Wbool-compare]
- if( ( m_LastDragOverAfter != wxNOT_FOUND ) && ( m_DragOverItem != wxNOT_FOUND ) )
-
-Build Warning:
-src/ApeTag.cpp:115:13: warning: ‘void WriteLittleEndianUint32(char*, wxUint32)’ defined but not used [-Wunused-function]
- static void WriteLittleEndianUint32( char * cp, wxUint32 i )
-
-Build Warning:
-src/wxsqlite3/wxsqlite3.cpp:3706:7: warning: variable ‘rc’ set but not used [-Wunused-but-set-variable]
-(warning against wxSqlite3 code)