summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Furry2015-11-19 10:59:57 -0700
committerScott Furry2015-11-19 10:59:57 -0700
commit60f3d54aa8f946f5afe1916501de6d1cf7188de4 (patch)
treeeb341ae125725a646af9bea8e3fd7e5d4546d75b
parent062731f51a7f378c5968f49a7df07d8af652d19e (diff)
downloadaur-60f3d54aa8f946f5afe1916501de6d1cf7188de4.tar.gz
Workaround for Edit Track ID3 Segmentation Fault
-rw-r--r--PKGBUILD9
-rw-r--r--README1
-rw-r--r--guayadeque_08_EditCrash.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4eb101a37517..19e8d6caf9ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=guayadeque
pkgver=0.3.7
-pkgrel=5
+pkgrel=6
pkgdesc='Lightweight music player'
arch=('i686' 'x86_64')
url='http://guayadeque.org/'
@@ -28,7 +28,8 @@ source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgve
'guayadeque_04_wxcurl.patch'
'guayadeque_05_wxSqlite_upgrade.patch'
'guayadeque_06_pixbuf_link.patch'
- 'guayadeque_07_player_display_fix.patch')
+ 'guayadeque_07_player_display_fix.patch'
+ 'guayadeque_08_EditCrash.patch')
sha256sums=('d23eb1247add0bef8d5fef834294d7cb3d7c5fc20db9022b86f618a13d359938'
'56ff5fae064fa421cb951a7c664550861e04ae4df8b692044e2a4785f238ce24'
'15b49c58be40a57ecb1d38e7055c1edc5aaf71e0164062cc5f2b8fb589530377'
@@ -39,7 +40,8 @@ sha256sums=('d23eb1247add0bef8d5fef834294d7cb3d7c5fc20db9022b86f618a13d359938'
'f6e8faedeac2ff47f6f2ea0ef3cb7737aafb9f7179b49313aac0f07b63783506'
'6bd07e63afe0aa7baf30b616d701e234fd1c304897053e3eb466acb2db818071'
'23d388711a17dc7e1487c740fd961ceb563a967d5866c5d5508865252be2d645'
- 'e2dbb71fc1d6118fa31d30f49382c16bb306130fc94118f3df9f0ea64c27ca0f')
+ 'e2dbb71fc1d6118fa31d30f49382c16bb306130fc94118f3df9f0ea64c27ca0f'
+ 'aaf355a3df930128da5c165b6ff07d06c3aa8ed4514522cc6a71e78634b5ee14')
BUILDFLDR='buildlocal'
prepare() {
@@ -54,6 +56,7 @@ prepare() {
patch -Np0 -i ../guayadeque_05_wxSqlite_upgrade.patch
patch -Np0 -i ../guayadeque_06_pixbuf_link.patch
patch -Np0 -i ../guayadeque_07_player_display_fix.patch
+ patch -Np0 -i ../guayadeque_08_EditCrash.patch
}
build() {
diff --git a/README b/README
index a433d81815dd..ab0e4c558c36 100644
--- a/README
+++ b/README
@@ -21,6 +21,7 @@ for their work and efforts which lead to this package.
guayadeque_05_wxSqlite_upgrade.patch (update internal wxSqlite3 to rev 3.2.1)
guayadeque_06_pixbuf_link.patch (add build link to libgdk-pixbuf-2.0.so)
guayadeque_07_player_display_fix.patch(correct current track display bug)
+ guayadeque_08_EditCrash.patch (workaround seg error when editing track ID3)
=====
KNOWN BUILD ISSUES
diff --git a/guayadeque_08_EditCrash.patch b/guayadeque_08_EditCrash.patch
new file mode 100644
index 000000000000..a8a44ea1e328
--- /dev/null
+++ b/guayadeque_08_EditCrash.patch
@@ -0,0 +1,13 @@
+diff --git src/TrackEdit.cpp src/TrackEdit.cpp
+index c38cec5..8cc4127 100644
+--- src/TrackEdit.cpp
++++ src/TrackEdit.cpp
+@@ -1959,7 +1959,7 @@ void inline guUpdateComboBoxEntries( wxComboBox * combobox, wxSortedArrayString
+ int Index;
+ int Count;
+
+- combobox->Clear();
++ //combobox->Clear();
+
+ if( curitem == wxNOT_FOUND )
+ return;