summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2022-03-19 22:02:11 +0100
committerpancho horrillo2022-03-19 22:02:11 +0100
commit273ac5f4abc974aead41029bade29f9298917495 (patch)
treea44a241120bf1ae43eead3027ccefdefe82a5db6
parenta295917423694bd6221db9689b3650934e94c365 (diff)
downloadaur-273ac5f4abc974aead41029bade29f9298917495.tar.gz
Apply fix by Toolybird (thanks!)
Also, enable tests, since they seem to work.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aed00f00d115..b248e504b4d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = guestfs-tools
pkgdesc = Tools for accessing and modifying guest disk images
pkgver = 1.46.1
- pkgrel = 1
+ pkgrel = 2
url = http://libguestfs.org/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index b30ef20fcf19..31631644dab3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
+# Maintainer: pancho horrillo <pancho at pancho dot name>
# Maintainer: David Thurstenson <thurstylark@gmail.com>
# Contributor: Toolybird <toolybird@tuta.io>
pkgname=guestfs-tools
pkgver=1.46.1
_pkgver_short=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for accessing and modifying guest disk images"
arch=('x86_64')
url="http://libguestfs.org/"
@@ -20,6 +21,12 @@ sha256sums=('93acc3aeaeda102c7134b40eb3b59bf3ef7d06f5cd44245ec1401bec77ba36a8'
'SKIP')
validpgpkeys=('F7774FB1AD074A7E8C8767EA91738F73E1B768A0') # Richard W.M. Jones <rjones@redhat.com>
+prepare() {
+ cd $pkgname-$pkgver
+ # quick hack to fix build
+ sed -i 's|CDEFLMPSUVYZX+52-3|+C+D+E+F+L+M+P+S+U+V+Y+Z+X+52-3-6 -w -6|' configure
+}
+
build() {
cd "$pkgname-$pkgver"
@@ -32,15 +39,15 @@ build() {
make
}
-#check() {
-# # needs access to /dev/kvm inside nspawn container
-# # 1 test will be skipped if unable to access /dev/fuse
-# # 2 tests fail that want librpm, skip both
-# cd "$pkgname-$pkgver"
-# SKIP_TEST_VIRT_INSPECTOR_SH=1 \
-# SKIP_TEST_VIRT_INSPECTOR_LUKS_SH=1 \
-# make check
-#}
+check() {
+ # needs access to /dev/kvm inside nspawn container
+ # 1 test will be skipped if unable to access /dev/fuse
+ # 2 tests fail that want librpm, skip both
+ cd "$pkgname-$pkgver"
+ SKIP_TEST_VIRT_INSPECTOR_SH=1 \
+ SKIP_TEST_VIRT_INSPECTOR_LUKS_SH=1 \
+ make check
+}
package() {
cd "$pkgname-$pkgver"