summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-12 13:44:02 +0800
committerzxp198210052023-10-12 13:44:02 +0800
commite7d7583ee0977ade334eb2635b3b5d81a34cae5b (patch)
tree21f92ac3b3f8209727ececd185561765529cd6f9
parentd90fb977b6f9915240b4dad451d9fadce41be747 (diff)
downloadaur-e7d7583ee0977ade334eb2635b3b5d81a34cae5b.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d605500229e..de0a2481b55c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gui-butler
pkgdesc = A wrapper for itch.io's butler which lets you take advantage of the basic features without having to go through a CLI or set up build scripts for each new project.
pkgver = 2.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://seansleblanc.itch.io/gui-butler
- arch = any
+ arch = x86_64
license = MIT
makedepends = npm
makedepends = gendesk
- makedepends = electron25
+ makedepends = nodejs>=18
depends = glibc
depends = expat
depends = cairo
@@ -33,7 +33,10 @@ pkgbase = gui-butler
depends = libcups
depends = mesa
conflicts = gui-butler
+ noextract = butler.zip
source = gui-butler-2.3.1.tar.gz::https://github.com/seleb/gui-butler/archive/refs/tags/v2.3.1.tar.gz
+ source = butler.zip::https://broth.itch.ovh/butler/linux-amd64/LATEST/archive/default
sha256sums = 22364d6b0ee54059e28cd7b12d863b3b6e3b1f71a1d672d9d9dce7442bd2bb3d
+ sha256sums = b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c
pkgname = gui-butler
diff --git a/PKGBUILD b/PKGBUILD
index 11139927aaaf..673de14397a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,36 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=gui-butler
pkgver=2.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A wrapper for itch.io's butler which lets you take advantage of the basic features without having to go through a CLI or set up build scripts for each new project."
-arch=('any')
+arch=('x86_64')
url="https://seansleblanc.itch.io/gui-butler"
_githuburl="https://github.com/seleb/gui-butler"
license=('MIT')
conflicts=("${pkgname}")
+noextract=("butler.zip")
depends=('glibc' 'expat' 'cairo' 'alsa-lib' 'libxdamage' 'gtk3' 'libxext' 'glib2' 'nspr' 'libxcb' 'libdrm' 'nss' 'libxfixes' \
'bash' 'at-spi2-core' 'gcc-libs' 'libxcomposite' 'dbus' 'libxrandr' 'pango' 'libx11' 'libxkbcommon' 'libcups' 'mesa')
-makedepends=('npm' 'gendesk' 'electron25')
-source=("${pkgname}-${pkgver}.tar.gz::${_githuburl}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('22364d6b0ee54059e28cd7b12d863b3b6e3b1f71a1d672d9d9dce7442bd2bb3d')
+makedepends=('npm' 'gendesk' 'nodejs>=18')
+source=("${pkgname}-${pkgver}.tar.gz::${_githuburl}/archive/refs/tags/v${pkgver}.tar.gz"
+ "butler.zip::https://broth.itch.ovh/butler/linux-amd64/LATEST/archive/default")
+sha256sums=('22364d6b0ee54059e28cd7b12d863b3b6e3b1f71a1d672d9d9dce7442bd2bb3d'
+ 'b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c')
+prepare() {
+ gendesk -f -n -q --categories "Development;Utility" --name "${pkgname}" --exec "${pkgname} --no-sandbox %U"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- npm install
+ npm install --force
npm run build
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/bin/${pkgname}-linux-x64/resources/app/butler"
+ bsdtar -xf "${srcdir}/butler.zip" -C "${srcdir}/${pkgname}-${pkgver}/bin/${pkgname}-linux-x64/resources/app/butler"
}
package() {
- install -Dm755 -d "${pkgdir}/opt/${pkgname}"
- cp -r "${srcdir}/${pkgname}-${pkgver}/bin/"${pkgname}-linux-*/* "${pkgdir}/opt/${pkgname}"
- install -Dm644 "${pkgdir}/opt/${pkgname}/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 "${pkgdir}/opt/${pkgname}/resources/app/favicon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- gendesk -f -n --icon "${pkgname}" --categories "Development;Utility" --name "${pkgname}" --exec "/opt/${pkgname}/${pkgname} %U"
+ install -Dm755 -d "${pkgdir}/"{opt/"${pkgname}",usr/bin}
+ cp -r "${srcdir}/${pkgname}-${pkgver}/bin/${pkgname}-linux-x64/"* "${pkgdir}/opt/${pkgname}"
+ ln -sf "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/favicon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file