summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2021-02-06 22:57:36 -0500
committerGI_Jack2021-02-06 22:57:36 -0500
commitd9f4e45c03331633d2b6a555b4ee6b9fb1d2f75e (patch)
tree076773d0353da78144f49e4a7121869804f74dee
downloadaur-d9f4e45c03331633d2b6a555b4ee6b9fb1d2f75e.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD28
-rw-r--r--guilded.install12
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad4a1d0bbff5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Sat Feb 6 10:57:26 PM EST 2021
+pkgbase = guilded
+ pkgdesc = Discord Chat App Knocoff(www.guilded.gg)
+ pkgver = 1.0.984969
+ pkgrel = 1
+ url = https://www.guilded.gg/
+ install = guilded.install
+ arch = x86_64
+ license = custom
+ depends = gtk3
+ depends = libnotify
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-core
+ depends = util-linux-libs
+ depends = libappindicator-gtk3
+ depends = libsecret
+ source = guilded-1.0.984969.deb::https://www.guilded.gg/downloads/Guilded-Linux.deb
+ sha256sums = b460ffed6d89bbb4cdfd393e65c7a4ac4ed10fb4624c139f8d1b16aa415662a1
+
+pkgname = guilded
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5865e6267cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+#
+# Some sloppy repackage of the debian version
+
+pkgname=guilded
+pkgver=1.0.984969
+pkgrel=1
+pkgdesc="Discord Chat App Knocoff(www.guilded.gg)"
+arch=('x86_64')
+url="https://www.guilded.gg/"
+license=('custom')
+depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'at-spi2-core'
+ 'util-linux-libs' 'libappindicator-gtk3' 'libsecret')
+options=()
+install="${pkgname}.install"
+changelog=
+source=("${pkgname}-${pkgver}.deb::https://www.guilded.gg/downloads/Guilded-Linux.deb")
+sha256sums=('b460ffed6d89bbb4cdfd393e65c7a4ac4ed10fb4624c139f8d1b16aa415662a1')
+
+prepare() {
+ tar Jxvf data.tar.xz
+}
+
+package() {
+ cd "${srcdir}"
+ cp -r usr "${pkgdir}"
+ cp -r opt "${pkgdir}"
+}
diff --git a/guilded.install b/guilded.install
new file mode 100644
index 000000000000..0fb3b7e2cc46
--- /dev/null
+++ b/guilded.install
@@ -0,0 +1,12 @@
+post_install() {
+ # Link to the binary
+ ln -sf '/opt/Guilded/guilded' '/usr/bin/guilded'
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+}
+
+post_remove() {
+ # Delete the link to the binary
+ rm -f '/usr/bin/guilded'
+}