summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2021-03-02 00:44:59 +0800
committerTing-Wei Lan2021-03-02 00:44:59 +0800
commit46598dffc368f39d95f58b1d33d00b512b13e4ad (patch)
tree6de4d4aaa351fe9b2dad3e06ec460eb3b8ee77e4
downloadaur-46598dffc368f39d95f58b1d33d00b512b13e4ad.tar.gz
guile-avahi: 0.4 (initial commit)
It is pulled in by Guix 1.2.0.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcf766f902fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = guile-avahi
+ pkgdesc = Avahi bindings for GNU Guile
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://www.nongnu.org/guile-avahi
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = LGPL3
+ depends = guile
+ depends = avahi
+ depends = gmp
+ source = https://download.savannah.nongnu.org/releases/guile-avahi/guile-avahi-0.4.tar.gz
+ sha256sums = 9dcc2810058cc87d8fa81a1fa8eb7a3892b2cc0a8786fb16fe88d260aa0ba669
+
+pkgname = guile-avahi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6341c4f39f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: lantw44 (at) gmail (dot) com
+
+pkgname=guile-avahi
+pkgver=0.4
+pkgrel=1
+pkgdesc='Avahi bindings for GNU Guile'
+arch=('x86_64' 'i686' 'armv7h')
+url='https://www.nongnu.org/guile-avahi'
+license=('LGPL3')
+depends=('guile' 'avahi' 'gmp')
+source=("https://download.savannah.nongnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('9dcc2810058cc87d8fa81a1fa8eb7a3892b2cc0a8786fb16fe88d260aa0ba669')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # Regenerate configure to allow using Guile < 3.
+ autoreconf -fi
+ ./configure --prefix=/usr \
+ --with-guilemoduledir=/usr/share/guile/site/2.2 \
+ --disable-rpath
+ make
+}
+
+check(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}