summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2017-12-10 11:07:42 +0800
committerTing-Wei Lan2017-12-10 11:07:42 +0800
commit127a0b2e13692f51c6ec2b616bc7d8d758413ea8 (patch)
tree116338c54cdc5229adf6182e9af66b5658857a14
downloadaur-127a0b2e13692f51c6ec2b616bc7d8d758413ea8.tar.gz
guile-bytestructures: 0.0+250+g7ed31b1 (initial commit)
It is pulled in by guile-git, guile bindings of libgit2.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3beab9c1b3fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Dec 10 03:07:43 UTC 2017
+pkgbase = guile-bytestructures
+ pkgdesc = Structured access library to bytevector contents for Guile
+ pkgver = 0.0+250+g7ed31b1
+ pkgrel = 1
+ url = https://github.com/TaylanUB/scheme-bytestructures
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ depends = guile
+ source = git+https://github.com/TaylanUB/scheme-bytestructures#commit=7ed31b1e93a4bf8960f1d4aedbea84f4f594af6d
+ sha256sums = SKIP
+
+pkgname = guile-bytestructures
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ee43a2df39c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: lantw44 (at) gmail (dot) com
+
+pkgname=guile-bytestructures
+_pkgname=scheme-bytestructures
+pkgver=0.0+250+g7ed31b1
+pkgrel=1
+pkgdesc='Structured access library to bytevector contents for Guile'
+arch=('x86_64' 'i686')
+url="https://github.com/TaylanUB/scheme-bytestructures"
+license=('GPL3')
+depends=('guile')
+makedepends=('git')
+_commit=7ed31b1e93a4bf8960f1d4aedbea84f4f594af6d
+source=("git+https://github.com/TaylanUB/${_pkgname}#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ printf "0.0+%s+g%s" \
+ "$(git rev-list HEAD | wc -l)" \
+ "$(git rev-list --max-count=1 HEAD | cut -c 1-7)"
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}