summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Sutter2022-09-18 17:38:20 -0400
committerBen Sutter2022-09-18 17:38:20 -0400
commit4d03e7cb6dc8cc79193279d572ae55198ab22888 (patch)
treea94d4a358d53f5203e113809601f656b2ff6926b
parent285978394abde7c9867a07771cc0a0b011f26653 (diff)
downloadaur-4d03e7cb6dc8cc79193279d572ae55198ab22888.tar.gz
small updates
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adc3ae165120..2bb08dd5162e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,22 @@ pkgdesc="Colorized Guile REPL from Git"
arch=('any')
url="https://gitlab.com/NalaGinrut/guile-colorized"
license=('GPL')
-makedepends=('git' 'sed')
-source=("$pkgname::git+https://gitlab.com/NalaGinrut/guile-colorized.git")
+makedepends=('git' 'sed' 'guile')
+provides=("guile-colorized=$pkgver")
+source=("${pkgname%-git}::git+https://gitlab.com/NalaGinrut/guile-colorized.git")
md5sums=('SKIP')
prepare() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
sed -i -e "s%^TARGET.\+:= %TARGET := $pkgdir%" -e 's%install:%install:\n mkdir -p \$\(TARGET\)\n%' Makefile
}
pkgver() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
git describe --long | sed 's%\([^-]*-g\)%r\1%;s%-%.%g'
}
package() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
make install
}