summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:22:44 +0200
committerStefan Husmann2015-06-09 00:22:44 +0200
commit922fa14794d4eda78c5bf849a423382029eb95e2 (patch)
tree06584c1736a58dc934acdba378e488bca0c785e9
downloadaur-922fa14794d4eda78c5bf849a423382029eb95e2.tar.gz
initial version
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD40
-rw-r--r--emacs.install28
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e529842512ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = guile-emacs-git
+ pkgdesc = branch of GNU Emacs that replaces Emacs' own EmacsLisp engine with that of Guile.
+ pkgver = 116892.41120e0
+ pkgrel = 1
+ url = http://www.emacswiki.org/emacs/GuileEmacs
+ install = emacs.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = librsvg
+ depends = guile4emacs-git
+ depends = giflib
+ depends = gtk3
+ depends = alsa-lib
+ depends = imagemagick
+ depends = gconf
+ depends = gpm
+ depends = m17n-lib
+ depends = desktop-file-utils
+ provides = emacs
+ provides = ctags
+ conflicts = emacs
+ conflicts = ctags
+ options = !strip
+ options = !makeflags
+ source = guilemacs::git://git.hcoop.net/git/bpt/emacs.git#branch=wip
+ md5sums = SKIP
+
+pkgname = guile-emacs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcf5d34e64e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=guile-emacs-git
+pkgver=116892.41120e0
+pkgrel=1
+pkgdesc="branch of GNU Emacs that replaces Emacs' own EmacsLisp engine with that of Guile."
+arch=('i686' 'x86_64')
+url="http://www.emacswiki.org/emacs/GuileEmacs"
+license=('GPL3')
+depends=('librsvg' 'guile4emacs-git' 'giflib' 'gtk3' 'alsa-lib' 'imagemagick' 'gconf' 'gpm' 'm17n-lib' 'desktop-file-utils')
+makedepends=('git')
+conflicts=('emacs' 'ctags')
+provides=('emacs' 'ctags')
+options=('!strip' '!makeflags')
+install=emacs.install
+source=("guilemacs::git://git.hcoop.net/git/bpt/emacs.git#branch=wip")
+md5sums=('SKIP')
+_gitname="guilemacs"
+
+pkgver() {
+ cd "$srcdir"/"$_gitname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir"/"$_gitname"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --with-jpeg=no
+ make
+}
+
+package() {
+ cd $srcdir/guilemacs
+ make DESTDIR="$pkgdir/" install
+ chown -R root:root $pkgdir/usr
+ # remove conflict with the texinfo-package
+ rm $pkgdir/usr/share/info/info.info.gz
+}
diff --git a/emacs.install b/emacs.install
new file mode 100644
index 000000000000..d35d7f4280e0
--- /dev/null
+++ b/emacs.install
@@ -0,0 +1,28 @@
+info_dir=/usr/share/info
+info_files=(ada-mode auth autotype calc ccmode cl dbus dired-x \
+ebrowse ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls \
+emacs-mime epa erc ert eshell eudc flymake forms gnus idlwave \
+mairix-el message mh-e newsticker nxml-mode org pcl-cvs pgg \
+rcirc reftex remember sasl sc semantic ses sieve smtpmail \
+speedbar tramp url vip viper widget woman)
+
+post_install() {
+ for f in ${info_files[@]}; do
+ install-info ${info_dir}/$f.info.gz ${info_dir}/dir 2> /dev/null
+ done
+ [ -e /usr/bin/gtk-update-icon-cache ] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor update-desktop-database -q 2> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ for f in ${info_files[@]}; do
+ install-info --delete ${info_dir}/$f.info.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+post_remove() {
+ [ -e /usr/bin/gtk-update-icon-cache ] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor update-desktop-database -q 2> /dev/null
+}