summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Update Bot2016-12-01 23:21:46 +0100
committerStefan Husmann2016-12-01 23:21:46 +0100
commit01e796f3114975366a8186453c5c6534edbe5f00 (patch)
tree17c1c8cab1a8bc4b32b285dfdd3cf27e930b99e8
parent76378a70fc6e159365f4b367d826e6ac56fd2532 (diff)
downloadaur-01e796f3114975366a8186453c5c6534edbe5f00.tar.gz
Updated version (2.1.4.114.g8bd5dae -> 2.1.4.115.ga9dc553).
Changelog ========= Fix two wait-condition-variable race conditions (a9dc553) Compile fluid-set! to VM opcode (8bd5dae) Ensure autoconf doesn't downgrade us to C99 (7b6b86f) Add weak-table fast path for update (668153d) Fix scm_weak_table_refq for undefined default (5a3bc32) Remove special support for fluids in GDB interface (0dcca77) Deprecate scm_from_contiguous_array (fa4a229) Document new array functions, with provisional names (0bd7562) New functions (array-for-each-cell, array-for-each-cell-in-order) (7ef9d0a) New functions array-from, array-from*, array-amend! (d1435ea) Do not use array handles in scm_vector (7b6d854) Special case for array-map! with three arguments (cd7fee8) Speed up for multi-arg cases of scm_ramap functions (31e9f8b) Support typed arrays in some sort functions (fa40c28) Remove deprecated array functions (09850ff) Reuse SCM_BYTEVECTOR_TYPED_LENGTH in scm_array_get_handle (85ac9cc) Avoid unneeded internal use of array handles (4e76679) Fix compilation of rank 0 typed array literals (d236d4d) Merge api-{data,compound}.texi (8b5f323) Add NEWS item about mutexes (2b0ffb8) Deprecate dynamic roots (dc2a560) Update join-thread docs (f927c70) Add asyncs test (1e92511) Inline interrupts (0858431) Refactor async handling to be FIFO (4ae4988) Remove SCM_DEBUG_CELL_ACCESSES==1 (705e3a8) Explicit interrupt handling in VM (4985ef1) Add handle-interrupts inst and compiler pass (ca74e3f) Slim thread cleanup (fcb4348) join-thread in Scheme (a521440) scm_spawn_thread uses call-with-new-thread (e447258) Fix crasher in scm_system_async_mark_for_thread (3f23688) More comments in threads.c (9ac2c99) Optimize lock-mutex (e0f1741) Improve mutexes / condition variable implementation (950e728) Refactor GC implications of thread sleep (6bb5119) Unlocked mutexes don't have owners (1ed9dea) Put mutex kind in SMOB flags (4110e7b) Rename Guile's internal mutexes and condvars (7fd10d2) Internal threads refactor (e7c658a) doc: Adjust capitalization for "HTTPS" and "GnuTLS". (6bdd955) web: Add https support through gnutls. (8f1db9f) Update NEWS. (f8de980) Minor editing in api-scheduling.texi (2c0c641) Update documentation on mutexes (16fe02a) scm_timed_lock_mutex replaces scm_lock_mutex_timed (03ffd72) Update mutex documentation (8d90775) Separate fat mutex unlock and wait operations (fc4df45) Back to simple unlock-mutex (56dd476) Replace scm_make_mutex_with_flags (7682461) Remove unchecked-unlock facility from Guile mutexes (c091613) Recursively locking a SRFI-18 mutex blocks (f1f68ff) SRFI-18 mutexes are not recursive (b43f114) Move more functionality to SRFI-18 mutex-unlock! (b197a6a) Remove fat mutex abandoned mutex error (f1b7eaa) Remove thread held pthread_mutex field (a3d0a7d) Remove thread-local weak mutex set (857aa58) SRFI-18 manages own mutex "abandoned" state (c6a8092) Remove lock-mutex owner facility (ecfa0b5) SRFI-18 threads disjoint from guile threads (3ce76c3) Update SRFI-18 documentation. (bb4e955) srfi-18 condition variables disjoint (846f7e1) Remove export srfi-18 never had (3794935) SRFI-18 mutexes disjoint from Guile mutexes (2559631) try-mutex in terms of mutex-lock (0f5a59b) Fix typo in threads documentation (10471f4) Deprecate critical sections (fcc6a7b) Threads no longer track critical section level (4b78b00) Remove call/cc assertion about critical sections (8fc9450) Remove last critical section use (65268ff) Mutex in dynamic linker (2e2396d) Remove critical section in scm_debug_options (399379b) Mutex instead of critical section in gc.c (42882bb) Mutex instead of critical section in GOOPS (e7e7a71) Simplify critical section implementation (b410667) Mutex instead of critical sectoin in symbol->keyword (c88d0cc) Mutexes instead of critical sections in stime.c (cfab7e3) Remove unused internal definitions (c77ccc5) regexec comment fix (4458377) sigaction critical section refactor. (465466c) threads: Use a mutex instead of a critical section. (0a66387) Add scm_yield to manual alongside yield (b2e7662) api-scheduling.texi: Syntactic cleanups. (4280c81) Remove thread cleanup facility (eeeee32) REPL server avoids thread cleanup handlers (94a3433) srfi-18: thread-terminate! without cleanup handlers (b85f033) cancel-thread can take arguments (a7114ce) Trim srfi-18 thread startup machinery (6bf9c65) Refactor thread-join! to use optional args. (59fdf9c) Rationalize exception handling in srfi-18 (8e305ee) srfi-18: Avoid call/cc. (789a4d8) srfi-18: Inline uses of srfi-18-exception-preserver. (c3f08aa) srfi-18: Use srfi-35 conditions. (177a058) srfi-18: Use parameters. (0d57476) srfi-18: Use lambda* optional arguments. (7078218) srfi-18: Simplify thread-sleep!, thread-terminate!. (bbcc128) srfi-18: Use `match' in thread-start!. (4d23c83) srfi-18: Improve style. (501c0e6) Fix srfi-34 indentation (e5399d3) cancel-thread via asyncs, not pthread_cancel (a04739b) Use atomics for async interrupts (c957ec7) Move call-with-new-thread to Scheme (f3bfe29) Fix tree-il code generation for ECMAscript `new' expression. (9807d2d) Move thread bindings to (ice-9 threads) (d74e0fe) Deferred module observers via a parameter (56b490a) Adapt run-server* to change to `accept'. (206dced) Small api-scheduling.texi reorder (efcc30f) Update "Asyncs" section of manual. (51d322b) NEWS item for deprecated user asyncs (7280681) Deprecate user asyncs (59f09d1) Deprecate arbiters (56d8d9a) Fold 2.1.4 news into 2.2 news (e61017a) Fix slot allocation for prompts (8622344) Texinfo serialization: add braces when needed (06e4091) Remove .gnuploadrc. (67a0b7d)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6f106227ca5..a79a4b719114 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Nov 28 00:20:47 UTC 2016
+# Thu Dec 1 22:21:45 UTC 2016
pkgbase = guile-git
pkgdesc = A portable, embeddable Scheme implementation (Git snapshot)
- pkgver = 2.1.4.114.g8bd5dae
+ pkgver = 2.1.4.115.ga9dc553
pkgrel = 1
url = http://www.gnu.org/software/guile/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 88661e3dace0..e5c0cc0736ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=guile-git
_gitname=guile
-pkgver=2.1.4.114.g8bd5dae
+pkgver=2.1.4.115.ga9dc553
pkgrel=1
pkgdesc="A portable, embeddable Scheme implementation (Git snapshot)"
arch=('i686' 'x86_64')