summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-10-29 16:31:39 +0100
committerhaawda2017-10-29 16:31:39 +0100
commit74c104e2d016a07aeaf7f53034a53c82e84a6bc7 (patch)
tree146887f10e4790392cad9b8cde0f37c865bc937e
parent1c71e6ade27b54cba5d7ed7807ede505d303290b (diff)
downloadaur-74c104e2d016a07aeaf7f53034a53c82e84a6bc7.tar.gz
add a patch for consistent version numbering
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--version.patch36
3 files changed, 35 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89d28eb84459..c61b4accc855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 26 22:42:16 UTC 2017
+# Sun Oct 29 15:31:00 UTC 2017
pkgbase = guile-git
pkgdesc = A portable, embeddable Scheme implementation (Git snapshot)
- pkgver = 2.2.2.56.g214e887db
+ pkgver = 3.0.0.74.g9d1235af9
pkgrel = 1
url = http://www.gnu.org/software/guile/
arch = i686
@@ -24,8 +24,8 @@ pkgbase = guile-git
options = libtool
source = git://git.sv.gnu.org/guile.git
source = version.patch
- md5sums = SKIP
- md5sums = db49b36d3c02ed4eb2d44609e9838e39
+ sha256sums = SKIP
+ sha256sums = 7f902891a717cd6606a6a768e6e59b40c96757cbfa9a2262722567bea31b3774
pkgname = guile-git
diff --git a/PKGBUILD b/PKGBUILD
index 8e93622b0bbf..fe277634c9f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=guile-git
-_gitname=guile
-pkgver=2.2.2.56.g214e887db
+pkgver=3.0.0.74.g9d1235af9
pkgrel=1
pkgdesc="A portable, embeddable Scheme implementation (Git snapshot)"
arch=('i686' 'x86_64' 'aarch64')
@@ -13,18 +12,23 @@ depends=('gc' 'libtool' 'libffi' 'libunistring' 'gmp' 'readline')
provides=('guile')
conflicts=('guile4emacs')
options=('!strip' '!makeflags' 'libtool')
-source=("git://git.sv.gnu.org/$_gitname.git" version.patch)
+source=("git://git.sv.gnu.org/${pkgname%-git}.git" version.patch)
url="http://www.gnu.org/software/guile/"
-md5sums=('SKIP'
- 'db49b36d3c02ed4eb2d44609e9838e39')
+sha256sums=('SKIP'
+ '7f902891a717cd6606a6a768e6e59b40c96757cbfa9a2262722567bea31b3774')
pkgver() {
- cd $_gitname
- git describe --tags |sed 's+-+.+g'|sed 's+^v++'
+ cd ${pkgname%-git}
+ git describe --tags |sed 's+-+.+g'|sed 's+^v++'|sed 's+2.2.2+3.0.0+'
+}
+
+prepare() {
+ cd ${pkgname%-git}
+ patch -Np1 < "$srcdir"/version.patch
}
build() {
- cd $_gitname
+ cd ${pkgname%-git}
./autogen.sh
./configure --prefix=/usr --disable-error-on-warning \
--program-suffix=3.0
@@ -32,7 +36,7 @@ build() {
}
package() {
- cd $_gitname
+ cd ${pkgname%-git}
make DESTDIR="$pkgdir/" install
cd $pkgdir/usr/share/info
for i in guile*
diff --git a/version.patch b/version.patch
index f9a4d13d78f8..fd985b078519 100644
--- a/version.patch
+++ b/version.patch
@@ -1,28 +1,28 @@
-diff -Naur guile.orig/GUILE-VERSION guile.new/GUILE-VERSION
---- guile.orig/GUILE-VERSION 2017-04-29 03:34:57.303108817 +0200
-+++ guile.new/GUILE-VERSION 2017-04-29 03:35:18.832977611 +0200
-@@ -2,10 +2,10 @@
+diff --git a/GUILE-VERSION b/GUILE-VERSION
+index a44c254fb..0db8a3b45 100644
+--- a/GUILE-VERSION
++++ b/GUILE-VERSION
+@@ -1,8 +1,8 @@
+ # -*-shell-script-*-
# Note: `GUILE_VERSION' is defined in `configure.ac' using `git-version-gen'.
- GUILE_MAJOR_VERSION=2
--GUILE_MINOR_VERSION=2
-+GUILE_MINOR_VERSION=3
- GUILE_MICRO_VERSION=2
+-GUILE_MAJOR_VERSION=2
+-GUILE_MINOR_VERSION=3
++GUILE_MAJOR_VERSION=3
++GUILE_MINOR_VERSION=0
+ GUILE_MICRO_VERSION=0
--GUILE_EFFECTIVE_VERSION=2.2
-+GUILE_EFFECTIVE_VERSION=2.3
-
-
- # All of the shared lib versioning info. Right now, for this to work
-diff -Naur guile.orig/meta/guile-config.in guile.new/meta/guile-config.in
---- guile.orig/meta/guile-config.in 2017-04-29 03:34:57.413108146 +0200
-+++ guile.new/meta/guile-config.in 2017-04-29 03:51:46.313688531 +0200
-@@ -77,7 +77,7 @@
+ GUILE_EFFECTIVE_VERSION=3.0
+diff --git a/meta/guile-config.in b/meta/guile-config.in
+index b3e4c3d94..5236476c4 100755
+--- a/meta/guile-config.in
++++ b/meta/guile-config.in
+@@ -77,7 +77,7 @@ exec "@installed_guile@" -e main -s $0 "$@"
(dle " " p " --help - show usage info (this message)")
(dle " " p " --help SUBCOMMAND - show help for SUBCOMMAND")))
-(define guile-module "guile-2.2")
-+(define guile-module "guile-2.3")
++(define guile-module "guile-3.0")
(define (pkg-config . args)
(let* ((real-args (cons %pkg-config-program args))