summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2018-07-15 17:05:39 +0800
committerTing-Wei Lan2018-07-15 17:05:39 +0800
commit9fbfe729a7f067f10bae62471a5a8396eecfdd55 (patch)
tree41f66d22222f5423797947a0ef1c9eabc9e443bc
parent72b61daeb0db9ef428073527ed9ba7eee35f8c49 (diff)
downloadaur-9fbfe729a7f067f10bae62471a5a8396eecfdd55.tar.gz
guile-git-lib: 0.0+170+g951a32c -> 0.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c96f36559c5d..e6b9d82a5e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 10 03:09:57 UTC 2017
+# Sun Jul 15 08:25:32 UTC 2018
pkgbase = guile-git-lib
pkgdesc = Guile bindings for libgit2
- pkgver = 0.0+170+g951a32c
+ pkgver = 0.1.0
pkgrel = 1
url = https://gitlab.com/guile-git/guile-git
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = guile-git-lib
depends = guile
depends = guile-bytestructures
depends = libgit2
- source = git+https://gitlab.com/guile-git/guile-git.git#commit=951a32c56cc4d80f8836e3c7394783e69c1fcbad
- sha256sums = SKIP
+ source = https://gitlab.com/guile-git/guile-git/uploads/e8c218ac7ae77b745c44d1ffbe34f1dd/guile-git-0.1.0.tar.gz
+ sha256sums = a119e6fb2812d1d60d47b4554ca22b433586589fc2fbc4dd380b724020dfa356
pkgname = guile-git-lib
diff --git a/PKGBUILD b/PKGBUILD
index 015a1a26304b..32f0c87c7c17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=guile-git-lib
_pkgname=guile-git
-pkgver=0.0+170+g951a32c
+pkgver=0.1.0
pkgrel=1
pkgdesc='Guile bindings for libgit2'
arch=('x86_64' 'i686')
@@ -10,30 +10,21 @@ url="https://gitlab.com/guile-git/guile-git"
license=('GPL3')
depends=('guile' 'guile-bytestructures' 'libgit2')
makedepends=('git')
-_commit=951a32c56cc4d80f8836e3c7394783e69c1fcbad
-source=("git+https://gitlab.com/${_pkgname}/${_pkgname}.git#commit=${_commit}")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/${_pkgname}"
- printf "0.0+%s+g%s" \
- "$(git rev-list HEAD | wc -l)" \
- "$(git rev-list --max-count=1 HEAD | cut -c 1-7)"
-}
+source=("https://gitlab.com/${_pkgname}/${_pkgname}/uploads/e8c218ac7ae77b745c44d1ffbe34f1dd/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('a119e6fb2812d1d60d47b4554ca22b433586589fc2fbc4dd380b724020dfa356')
build() {
- cd "${srcdir}/${_pkgname}"
- ./bootstrap
+ cd "${srcdir}/${_pkgname}-${pkgver}"
./configure --prefix=/usr
make
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
make check
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}