summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaume Delclòs Coll2016-07-10 23:18:23 +0200
committerJaume Delclòs Coll2016-07-10 23:18:23 +0200
commit7c56e35fbacf6592bcbf5a81c8bc2f7d52b3c7f8 (patch)
treee6f752caa764d184f401543fcfcb801cc71617a0
parent9e5e1238d75c44b5069fcef34a10480122c1ea95 (diff)
downloadaur-7c56e35fbacf6592bcbf5a81c8bc2f7d52b3c7f8.tar.gz
update and simplify
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--guile-gnome-platform.install43
3 files changed, 11 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a41b9b4469f..c142d38da91f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = guile-gnome-platform
pkgdesc = Binding between Guile Scheme and the Gnome stack of libraries. (fe. Pango, GTK+, Cairo, GStreamer, Glade, GtkSourceView and else). To build wrappers for GTK+ and higher in the stack, you will first need Guile-Cairo.
- pkgver = 2.16.3
+ pkgver = 2.16.4
pkgrel = 1
- epoch = 1
url = http://www.gnu.org/software/guile-gnome/
- install = guile-gnome-platform.install
arch = i686
arch = x86_64
license = GPL2
- makedepends = gcc49
depends = g-wrap
depends = guile-cairo
depends = libgnomeui
provides = guile-gnome-platform
conflicts = guile-gnome-platform
options = !libtool
- source = http://git.savannah.gnu.org/cgit/guile-gnome.git/snapshot/guile-gnome-2.16.3.tar.gz
- md5sums = 0f48e1a90c72d813e47b567e03264ac1
+ source = http://ftp.gnu.org/pub/gnu/guile-gnome/guile-gnome-platform/guile-gnome-platform-2.16.4.tar.gz
+ md5sums = 930178554957a25209c6ca0adeb3a584
pkgname = guile-gnome-platform
diff --git a/PKGBUILD b/PKGBUILD
index c753bfa1268d..6b17f354e1e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,26 @@
# Contributor: Daniel Krueger <keenbug gmail.com>
# Contributor: Daniel Oliveira <psykond@gmail.com>
pkgname=guile-gnome-platform
-_pkgname=guile-gnome
-pkgver=2.16.3
+pkgver=2.16.4
pkgrel=1
-epoch=1
pkgdesc="Binding between Guile Scheme and the Gnome stack of libraries. (fe. Pango, GTK+, Cairo, GStreamer, Glade, GtkSourceView and else). To build wrappers for GTK+ and higher in the stack, you will first need Guile-Cairo."
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/guile-gnome/"
license=('GPL2')
depends=('g-wrap' 'guile-cairo' 'libgnomeui')
-makedepends=('gcc49')
provides=($pkgname)
conflicts=($pkgname)
-install=guile-gnome-platform.install
options=(!libtool)
-# once it's available, switch to this url
-#source=("http://ftp.gnu.org/pub/gnu/guile-gnome/$pkgname/$pkgname-$pkgver.tar.gz")
-source=("http://git.savannah.gnu.org/cgit/guile-gnome.git/snapshot/guile-gnome-$pkgver.tar.gz")
-md5sums=('0f48e1a90c72d813e47b567e03264ac1')
-
-pkgver() {
- cd $_pkgname-$pkgver
- git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,-,.,g'
-}
-
-prepare() {
- cd $_pkgname-$pkgver
- ./autogen.sh --prefix=/usr
-}
+source=("http://ftp.gnu.org/pub/gnu/guile-gnome/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('930178554957a25209c6ca0adeb3a584')
build() {
- cd $_pkgname-$pkgver
- CC=gcc-4.9 ./configure --prefix=/usr
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
make
}
-package() {
- cd $_pkgname-$pkgver
+
+package() {
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
}
diff --git a/guile-gnome-platform.install b/guile-gnome-platform.install
deleted file mode 100644
index 7999aa20b7c7..000000000000
--- a/guile-gnome-platform.install
+++ /dev/null
@@ -1,43 +0,0 @@
-infodir=usr/share/info
-_file_prefix='guile-gnome-'
-filelist=('gobject.info'
- 'glib.info'
- 'atk.info'
- 'pango.info'
- 'pangocairo.info'
- 'gdk.info'
- 'gdk.info-1'
- 'gdk.info-2'
- 'gtk.info'
- 'gtk.info-1'
- 'gtk.info-2'
- 'gtk.info-3'
- 'gtk.info-4'
- 'gtk.info-5'
- 'libgnomeui.info'
- 'libgnomecanvas.info'
- 'libgnome.info'
- 'libglade.info'
- 'gnome-vfs.info'
- 'gconf.info'
- 'corba.info')
-
-post_install() {
- [[ -x usr/bin/install-info ]] || return 0
- for file in "${filelist[@]}"; do
- install-info "$infodir/$_file_prefix$file.gz" "$infodir/dir" 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install "$1"
-}
-
-pre_remove() {
- [[ -x usr/bin/install-info ]] || return 0
- for file in "${filelist[@]}"; do
- install-info --delete "$infodir/$_file_prefix$file.gz" "$infodir/dir" 2> /dev/null
- done
-}
-
-# vim:set ts=2 sw=2 et: