summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaume Delclòs Coll2015-11-06 21:05:49 +0100
committerJaume Delclòs Coll2015-11-06 21:05:49 +0100
commit9e5e1238d75c44b5069fcef34a10480122c1ea95 (patch)
tree6ffab1766a3f4487bd55e96500bfd1a947f1c7b2
parentb5ac0eb9a982bbf5524eb7a978b99eac45e5135e (diff)
downloadaur-9e5e1238d75c44b5069fcef34a10480122c1ea95.tar.gz
Make guile-gnome-platform from guile-gnome-platform-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
-rw-r--r--guile-gnome-platform.install (renamed from guile-gnome-platform-git.install)0
3 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f089c034164..6a41b9b4469f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
-pkgbase = guile-gnome-platform-git
+pkgbase = guile-gnome-platform
pkgdesc = Binding between Guile Scheme and the Gnome stack of libraries. (fe. Pango, GTK+, Cairo, GStreamer, Glade, GtkSourceView and else). To build wrappers for GTK+ and higher in the stack, you will first need Guile-Cairo.
- pkgver = 2.16.2.r11.g0fcbe69
+ pkgver = 2.16.3
pkgrel = 1
epoch = 1
url = http://www.gnu.org/software/guile-gnome/
- install = guile-gnome-platform-git.install
+ install = guile-gnome-platform.install
arch = i686
arch = x86_64
license = GPL2
- makedepends = git
+ makedepends = gcc49
depends = g-wrap
depends = guile-cairo
depends = libgnomeui
provides = guile-gnome-platform
conflicts = guile-gnome-platform
options = !libtool
- source = guile-gnome-platform::git://git.sv.gnu.org/guile-gnome.git
- md5sums = SKIP
+ source = http://git.savannah.gnu.org/cgit/guile-gnome.git/snapshot/guile-gnome-2.16.3.tar.gz
+ md5sums = 0f48e1a90c72d813e47b567e03264ac1
-pkgname = guile-gnome-platform-git
+pkgname = guile-gnome-platform
diff --git a/PKGBUILD b/PKGBUILD
index ef118027e380..c753bfa1268d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Daniel Krueger <keenbug gmail.com>
+# Maintainer: Jaume Delclòs <jaume@delclos.com>
+# Contributor: Daniel Krueger <keenbug gmail.com>
# Contributor: Daniel Oliveira <psykond@gmail.com>
-pkgname=guile-gnome-platform-git
-_pkgname=guile-gnome-platform
-pkgver=2.16.2.r11.g0fcbe69
+pkgname=guile-gnome-platform
+_pkgname=guile-gnome
+pkgver=2.16.3
pkgrel=1
epoch=1
pkgdesc="Binding between Guile Scheme and the Gnome stack of libraries. (fe. Pango, GTK+, Cairo, GStreamer, Glade, GtkSourceView and else). To build wrappers for GTK+ and higher in the stack, you will first need Guile-Cairo."
@@ -10,30 +11,32 @@ arch=('i686' 'x86_64')
url="http://www.gnu.org/software/guile-gnome/"
license=('GPL2')
depends=('g-wrap' 'guile-cairo' 'libgnomeui')
-provides=($_pkgname)
-conflicts=($_pkgname)
-makedepends=('git')
-install=guile-gnome-platform-git.install
+makedepends=('gcc49')
+provides=($pkgname)
+conflicts=($pkgname)
+install=guile-gnome-platform.install
options=(!libtool)
-source=("$_pkgname::git://git.sv.gnu.org/guile-gnome.git")
-md5sums=('SKIP')
+# once it's available, switch to this url
+#source=("http://ftp.gnu.org/pub/gnu/guile-gnome/$pkgname/$pkgname-$pkgver.tar.gz")
+source=("http://git.savannah.gnu.org/cgit/guile-gnome.git/snapshot/guile-gnome-$pkgver.tar.gz")
+md5sums=('0f48e1a90c72d813e47b567e03264ac1')
pkgver() {
- cd $_pkgname
+ cd $_pkgname-$pkgver
git describe --long --tags | sed -E 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,-,.,g'
}
prepare() {
- cd $_pkgname
+ cd $_pkgname-$pkgver
./autogen.sh --prefix=/usr
}
build() {
- cd $_pkgname
- ./configure --prefix=/usr
+ cd $_pkgname-$pkgver
+ CC=gcc-4.9 ./configure --prefix=/usr
make
}
package() {
- cd $_pkgname
+ cd $_pkgname-$pkgver
make DESTDIR="$pkgdir/" install
}
diff --git a/guile-gnome-platform-git.install b/guile-gnome-platform.install
index 7999aa20b7c7..7999aa20b7c7 100644
--- a/guile-gnome-platform-git.install
+++ b/guile-gnome-platform.install