summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Sutter2022-10-04 13:41:47 -0400
committerBen Sutter2022-10-04 13:41:47 -0400
commitae7bb48cb170254b62fad3fe7dd0bf1a9c2fd822 (patch)
tree2f8e9f911ae6a7a63a02a40113708d1765cf175e
parente9dd3de4ae3043a65155fd4065acf908beca2a74 (diff)
downloadaur-ae7bb48cb170254b62fad3fe7dd0bf1a9c2fd822.tar.gz
respect xdg
-rw-r--r--PKGBUILD6
-rw-r--r--guile-hall-git-xdg-fix.patch41
2 files changed, 10 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c87f3da86642..ffb783b3fa03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-#PKGBUILD was last modified on September 27, 2022 at 03:54 PM EDT by bms#
+#PKGBUILD was last modified on October 04, 2022 at 01:37 PM EDT by bms#
# Maintainer: Ben Sutter <benjaminsutter@outlook.com>
pkgname=guile-hall-git
pkgver=0.4.1.r30.g36dd0c6
-pkgrel=2
+pkgrel=3
pkgdesc="Project manager and build tool for GNU guile (Git snapshot)"
arch=('i686' 'x86_64' 'aarch64')
license=('GPL')
@@ -15,7 +15,7 @@ source=("${pkgname%-git}::git+https://gitlab.com/a-sassmannshausen/guile-hall.gi
"guile-hall-git-xdg-fix.patch")
url="https://gitlab.com/a-sassmannshausen/guile-hall"
sha256sums=('SKIP'
- '0ea14d5f9fcf8ccf81c6235be643109671d7db691e3f8e55eca4d1326851224d')
+ '18cdf8108554c2b3f581563367e095a30e9f107f0d9148dae4c1e508025a8845')
options=(!strip)
pkgver() {
diff --git a/guile-hall-git-xdg-fix.patch b/guile-hall-git-xdg-fix.patch
index 8dfb32a6939c..41523e3ba098 100644
--- a/guile-hall-git-xdg-fix.patch
+++ b/guile-hall-git-xdg-fix.patch
@@ -1,35 +1,5 @@
-commit a219be1da65ac527d839db0c74f2c0bb6774ae84
-Author: Ben Sutter <14796185+bms-1984@users.noreply.github.com>
-Date: Sun Sep 25 06:45:27 2022 -0400
-
- add xdg config file
-
-diff --git a/doc/hall.texi b/doc/hall.texi
-index 5bc876a..e2fdaca 100644
---- a/doc/hall.texi
-+++ b/doc/hall.texi
-@@ -334,7 +334,7 @@ The special switches @option{--help}, @option{--version},
- @option{--usage} and @option{--cmdtree} are always available. They
- will act as your guides as you explore the lands of Hall.
- @item
--Hall has a configuration file located at @file{~/.hall}. You can set
-+Hall has a configuration file located at @file{~/.hall} or at @file{~/.config/hall/hall}. You can set
- some settings there, to provide default values for all your projects.
- @end itemize
-
-@@ -362,8 +362,8 @@ convert an existing Guile project to use Hall (using the
-
- Outside of the standard options, @command{init} also accepts
- @option{--author}, @option{--license}, @option{--prefix} and
--@option{--website}. All of these can be set in the @file{~/.hall}
--configuration file.
-+@option{--website}. All of these can be set in the @file{~/.hall} and @file{~/.config/hall/hall}
-+configuration files.
-
- It also accepts the special @option{--convert} switch, which will
- probably become a subcommand in the near future.
diff --git a/scripts/hall.in b/scripts/hall.in
-index d14269e..90c0c1e 100644
+index d14269e..71da3d7 100644
--- a/scripts/hall.in
+++ b/scripts/hall.in
@@ -149,8 +149,7 @@ distribution file.")
@@ -42,14 +12,17 @@ index d14269e..90c0c1e 100644
'--convert' can be used when you have an existing project that you want to
start using hall for.
-@@ -221,7 +220,9 @@ first.")
+@@ -221,7 +220,12 @@ first.")
(handler (cut string-split <> #\,))
(synopsis "CSV list regexp patterns to indicate files to skip.")
(example "scripts/foo,AUTHORS,^.*rgp$")))))))
- (directory (in-home "."))
+ (directory (list
-+ (in-home ".config/hall/" #t)
-+ (in-home "." #t)))
++ (path (given (string-append (let ((xdg (getenv "XDG_CONFIG_HOME")))
++ (if (> (string-length xdg) 0)
++ xdg
++ (string-append (getenv "HOME") "/.config"))) "/hall/"))
++ (eager? #t))))
(parser simple-sexp-parser)))
(define* (main #:optional (args (command-line)))