summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Oteiza2015-06-08 22:47:17 -0400
committerMark Oteiza2015-06-08 22:47:17 -0400
commit4feabe3d1313118d1676552e504933ed821046e0 (patch)
treee2a4a14d4ba9f45814377dff369c984a775c3df6
downloadaur-4feabe3d1313118d1676552e504933ed821046e0.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7a24f55ecb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = guile-json
+ pkgdesc = JSON module for Guile
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/aconchillo/guile-json
+ arch = any
+ license = LGPL
+ source = http://download.savannah.gnu.org/releases/guile-json/guile-json-0.4.0.tar.gz
+ sha256sums = 0696062439ceb00d1026e9c352e8a6fac22de6fd6e38a9f5e7cc139ec511066c
+
+pkgname = guile-json
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77b60a437cde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: holos
+# Contributor: tantalum
+
+pkgname=guile-json
+pkgrel=1
+pkgver=0.4.0
+pkgdesc='JSON module for Guile'
+url="https://github.com/aconchillo/guile-json"
+arch=('any')
+license=('LGPL')
+source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('0696062439ceb00d1026e9c352e8a6fac22de6fd6e38a9f5e7cc139ec511066c')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}