summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2019-05-17 22:21:14 +0800
committerTing-Wei Lan2019-05-17 22:30:14 +0800
commitd463ea92ad9e9a31a3532b838bc946c0574b6273 (patch)
tree5c2943baa35dc7bde3a0caec5985a0c0eaac9fb8
downloadaur-guile-json1.tar.gz
guile-json1: 0.1.0 (initial commit)
This packages is forked from guile-json to support Guix, which has not been updated to work with the latest version of guile-json.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed07aa0995b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = guile-json1
+ pkgdesc = JSON module for Guile (Version 1)
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://savannah.nongnu.org/projects/guile-json
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = GPL3
+ depends = guile
+ provides = guile-json=1.3.2
+ conflicts = guile-json
+ source = https://download.savannah.gnu.org/releases/guile-json/guile-json-1.3.2.tar.gz
+ sha256sums = 33f94ea73c478faeca0d56c6d4c12591cb18956476da314df9d1e464c2fade54
+
+pkgname = guile-json1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d028734917b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Forked from guile-json 1.2.0 PKGBUILD
+
+# Maintainer: lantw44
+# Contributor: holos
+# Contributor: tantalum
+
+pkgname=guile-json1
+_pkgname=guile-json
+pkgver=1.3.2
+pkgrel=1
+pkgdesc='JSON module for Guile (Version 1)'
+arch=('x86_64' 'i686' 'armv7h')
+url='https://savannah.nongnu.org/projects/guile-json'
+license=('GPL3')
+depends=('guile')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("https://download.savannah.gnu.org/releases/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('33f94ea73c478faeca0d56c6d4c12591cb18956476da314df9d1e464c2fade54')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}