summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-10 19:36:46 -0600
committerBrian Bidulock2015-07-10 19:48:46 -0600
commit19c829cd50641a3e95e73efa86556de992f2ee71 (patch)
tree7de18c4b93835a919587c915f4f2d0e8567946a1
parent63fe9bb66bba14f3179b060d762bb8238cf6622c (diff)
downloadaur-19c829cd50641a3e95e73efa86556de992f2ee71.tar.gz
version 0.2.2-1
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
3 files changed, 30 insertions, 22 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..cb423c73d049
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = guile-lib
+ pkgdesc = Repository of useful code written in Guile Scheme
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = http://www.nongnu.org/guile-lib/
+ arch = i686
+ arch = x86_64
+ license = GPL3 and LGPL3
+ depends = guile
+ source = http://download.savannah.gnu.org/releases/guile-lib/guile-lib-0.2.2.tar.gz
+
+pkgname = guile-lib
+
diff --git a/.SRCINFO b/.SRCINFO
index df72227b1f37..961790799124 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = guile-lib
pkgdesc = Repository of useful code written in Guile Scheme
pkgver = 0.2.2
- pkgrel = 2
+ pkgrel = 1
url = http://www.nongnu.org/guile-lib/
- install = guile-lib.install
arch = i686
arch = x86_64
- license = GPL3
- license = LGPL3
+ license = GPL3 and LGPL3
depends = guile
source = http://download.savannah.gnu.org/releases/guile-lib/guile-lib-0.2.2.tar.gz
md5sums = 77427e4ff3f2b1061bffa370666125f7
diff --git a/PKGBUILD b/PKGBUILD
index 290876837825..679921e13fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
-# Maintainer: Brian Bidulock <bidulock@openss7.org>
-# Contributor: tantalum <tantalum at online dot de>
+# contributor: tantalum <tantalum at online dot de>
pkgname=guile-lib
pkgver=0.2.2
-pkgrel=2
+pkgrel=1
pkgdesc='Repository of useful code written in Guile Scheme'
-arch=('i686' 'x86_64')
-license=('GPL3' 'LGPL3')
-depends=('guile')
-url="http://www.nongnu.org/guile-lib/"
-install=$pkgname.install
+arch=(i686 x86_64)
+license=("GPL3 and LGPL3")
+depends=(guile)
+url=http://www.nongnu.org/guile-lib/
source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('77427e4ff3f2b1061bffa370666125f7')
-
+md5sums=(77427e4ff3f2b1061bffa370666125f7)
build(){
- cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr
- make
-}
+ cd ${srcdir}/${pkgname}-${pkgver} &&
+
+ ./configure --prefix=/usr || return 1
+ make && make DESTDIR=${pkgdir} install || return 1
-package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
- rm -f "${pkgdir}/usr/share/info/dir"
+ #remove documentation
+ if [ -e ${pkgdir}/usr/share/info/dir ]; then
+ rm ${pkgdir}/usr/share/info/dir
+ fi
}