summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-10 19:48:18 -0600
committerBrian Bidulock2015-07-10 19:48:46 -0600
commit63c7f72a9ab47ca6d5453a480a58d658fff5f47d (patch)
treee56c3cc2e0c4cd3eda3db263f2ebdb21ba8f8f43
parent19c829cd50641a3e95e73efa86556de992f2ee71 (diff)
downloadaur-63c7f72a9ab47ca6d5453a480a58d658fff5f47d.tar.gz
version 0.2.2-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 961790799124..df72227b1f37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = guile-lib
pkgdesc = Repository of useful code written in Guile Scheme
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.nongnu.org/guile-lib/
+ install = guile-lib.install
arch = i686
arch = x86_64
- license = GPL3 and LGPL3
+ license = GPL3
+ license = LGPL3
depends = guile
source = http://download.savannah.gnu.org/releases/guile-lib/guile-lib-0.2.2.tar.gz
md5sums = 77427e4ff3f2b1061bffa370666125f7
diff --git a/PKGBUILD b/PKGBUILD
index 679921e13fd6..290876837825 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
-# contributor: tantalum <tantalum at online dot de>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: tantalum <tantalum at online dot de>
pkgname=guile-lib
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='Repository of useful code written in Guile Scheme'
-arch=(i686 x86_64)
-license=("GPL3 and LGPL3")
-depends=(guile)
-url=http://www.nongnu.org/guile-lib/
+arch=('i686' 'x86_64')
+license=('GPL3' 'LGPL3')
+depends=('guile')
+url="http://www.nongnu.org/guile-lib/"
+install=$pkgname.install
source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=(77427e4ff3f2b1061bffa370666125f7)
-build(){
- cd ${srcdir}/${pkgname}-${pkgver} &&
+md5sums=('77427e4ff3f2b1061bffa370666125f7')
- ./configure --prefix=/usr || return 1
- make && make DESTDIR=${pkgdir} install || return 1
+build(){
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
- #remove documentation
- if [ -e ${pkgdir}/usr/share/info/dir ]; then
- rm ${pkgdir}/usr/share/info/dir
- fi
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rm -f "${pkgdir}/usr/share/info/dir"
}