summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-10 19:48:45 -0600
committerBrian Bidulock2015-07-10 19:48:45 -0600
commit63fe9bb66bba14f3179b060d762bb8238cf6622c (patch)
treee6af11428b67788772854256ad0b3687bdb924aa
downloadaur-63fe9bb66bba14f3179b060d762bb8238cf6622c.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--guile-lib.install20
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df72227b1f37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = guile-lib
+ pkgdesc = Repository of useful code written in Guile Scheme
+ pkgver = 0.2.2
+ pkgrel = 2
+ url = http://www.nongnu.org/guile-lib/
+ install = guile-lib.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ depends = guile
+ source = http://download.savannah.gnu.org/releases/guile-lib/guile-lib-0.2.2.tar.gz
+ md5sums = 77427e4ff3f2b1061bffa370666125f7
+
+pkgname = guile-lib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..290876837825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: tantalum <tantalum at online dot de>
+pkgname=guile-lib
+pkgver=0.2.2
+pkgrel=2
+pkgdesc='Repository of useful code written in Guile Scheme'
+arch=('i686' 'x86_64')
+license=('GPL3' 'LGPL3')
+depends=('guile')
+url="http://www.nongnu.org/guile-lib/"
+install=$pkgname.install
+source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('77427e4ff3f2b1061bffa370666125f7')
+
+build(){
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rm -f "${pkgdir}/usr/share/info/dir"
+}
diff --git a/guile-lib.install b/guile-lib.install
new file mode 100644
index 000000000000..64d89567017b
--- /dev/null
+++ b/guile-lib.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(guile-library.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}