summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsph2019-06-05 20:44:34 +0200
committersph2019-06-05 20:44:34 +0200
commit69d9a0f18701b91a2819ad7de770b2f633b275c8 (patch)
tree7807df4e1203bcbbc5cabbd014b504152b8022a9
parentc513dd9ad2de961bafc06da63ecc7eb2716bdc64 (diff)
downloadaur-69d9a0f18701b91a2819ad7de770b2f633b275c8.tar.gz
apply patch by Jarhmander
-rwxr-xr-xPKGBUILD30
-rw-r--r--fix-build-path.patch11
-rw-r--r--guile-wisp-hg.install12
3 files changed, 31 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 724ec9dab9c5..c2d21bb399bb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,37 @@
_name=wisp
pkgname=guile-$_name-hg
-pkgver=r1623.9b0863aad000
+pkgver=r1628+.62d6a170aefd+
pkgrel=1
-pkgdesc="wisp is a whitespace to lisp converter (srfi-119). guile module"
+pkgdesc="Whitespace to Lisp converter (srfi-119) as a guile module"
arch=(any)
license=(gpl3+)
makedepends=(mercurial)
depends=("guile>=2")
provides=("$_name")
-source=("hg+https://bitbucket.org/ArneBab/wisp#branch=stable")
+source=("hg+https://bitbucket.org/ArneBab/wisp"
+ "fix-build-path.patch")
url="http://www.draketo.de/english/wisp"
-md5sums=(SKIP)
-install="$pkgname.install"
+md5sums=(SKIP
+ SKIP)
pkgver() {
cd "$srcdir/$_name" &&
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
+prepare() {
+ cd "$srcdir/$_name"
+ patch -i "${srcdir}/fix-build-path.patch"
+}
+
+build() {
+ cd "$srcdir/$_name"
+ autoreconf -i
+ ./configure --datarootdir=/usr/share
+ make
+}
+
package() {
- cd "$srcdir/$_name" &&
- autoreconf -i &&
- ./configure --datarootdir=/usr/share &&
- make &&
+ cd "$srcdir/$_name"
make install DESTDIR="$pkgdir"
-} \ No newline at end of file
+}
diff --git a/fix-build-path.patch b/fix-build-path.patch
new file mode 100644
index 000000000000..cbe0e07c733a
--- /dev/null
+++ b/fix-build-path.patch
@@ -0,0 +1,11 @@
+--- wisp/Makefile.am.orig 2019-06-04 18:08:38.341783769 -0400
++++ wisp/Makefile.am 2019-06-04 18:03:12.011228420 -0400
+@@ -34,7 +34,7 @@
+
+ # precompile all scheme files
+ .scm.go:
+- $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
++ $(GUILE_TOOLS) compile -L . $(GUILE_WARNINGS) -o "$@" "$<"
+
+ wisp2lisp: wisp.scm ## build only the wisp2lisp converter
+ cp $< $@
diff --git a/guile-wisp-hg.install b/guile-wisp-hg.install
index e46456563caa..e69de29bb2d1 100644
--- a/guile-wisp-hg.install
+++ b/guile-wisp-hg.install
@@ -1,12 +0,0 @@
-post_install() {
- echo post-install message:
- echo
- echo execute &&
- echo " guile" -c '"(import (language wisp spec))"' &&
- echo to prevent compile warnings when starting a wisp repl.
- echo
-}
-
-post_update() {
- post_install
-} \ No newline at end of file