summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-05-30 00:07:24 +0200
committerhaawda2017-05-30 00:07:24 +0200
commit3d537dabff933ea86eea5e025b4d2c180c1846a8 (patch)
tree1829d900c9bc314f22e15a4bd1be45e15c1457b3
parent851bd632b6a0fd9105996774c93f5b73ea7ddb66 (diff)
downloadaur-3d537dabff933ea86eea5e025b4d2c180c1846a8.tar.gz
fix PKGBUILD to really download the most recent sources, new pkgver function
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3b247a8ab73..c3baa5a3b15e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun May 7 16:08:02 UTC 2017
pkgbase = guile-wm-git
pkgdesc = Windowmanagement environment for guile
- pkgver = 20170507.be8b6d1
+ pkgver = 1.0.6.gf3c7b3b
pkgrel = 1
url = http://www.markwitmer.com/guile-xcb/guile-wm.html
arch = any
@@ -13,7 +11,7 @@ pkgbase = guile-wm-git
provides = guile-wm
conflicts = guile-wm
options = !makeflags
- source = git+https://github.com/mwitmer/guile-wm
+ source = git+https://github.com/mwitmer/guile-wm.git
md5sums = SKIP
pkgname = guile-wm-git
diff --git a/PKGBUILD b/PKGBUILD
index 2c08ef248c61..9b4230c16b36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=guile-wm-git
-pkgver=20170507.be8b6d1
+pkgver=1.0.6.gf3c7b3b
pkgrel=1
pkgdesc="Windowmanagement environment for guile"
arch=('any')
@@ -10,13 +10,14 @@ depends=('guile' 'guile-xcb')
makedepends=('git')
provides=('guile-wm')
conflicts=('guile-wm')
-source=("git+https://github.com/mwitmer/guile-wm")
+source=("git+https://github.com/mwitmer/guile-wm.git")
md5sums=('SKIP')
options=('!makeflags')
_gitname="guile-wm"
pkgver() {
- git log -1 --format='%cd.%h' --date=short | tr -d -
+ cd $_gitname
+ printf %s $(git describe --tags | tr - .)
}
prepare() {