summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2021-03-02 00:44:59 +0800
committerTing-Wei Lan2021-03-02 00:44:59 +0800
commitc654301d0acd36481e08e741be6f548768446d2c (patch)
tree8ee6d7db6bdc857c9ae98ee800c566142f0c0533
downloadaur-c654301d0acd36481e08e741be6f548768446d2c.tar.gz
guile-zlib: 0.0.1 (initial commit)
It is pulled in by Guix 1.2.0.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e9736ac6a62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = guile-zlib
+ pkgdesc = Guile bindings for zlib
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://notabug.org/guile-zlib/guile-zlib
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = GPL3
+ depends = guile
+ depends = zlib
+ source = guile-zlib-0.0.1.tar.gz::https://notabug.org/guile-zlib/guile-zlib/archive/0.0.1.tar.gz
+ sha256sums = f1100be6dd31b02983cf498155bf11155ca833421f99698f29e5694317335fb1
+
+pkgname = guile-zlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c74f83a37524
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: lantw44 (at) gmail (dot) com
+
+pkgname=guile-zlib
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Guile bindings for zlib'
+arch=('x86_64' 'i686' 'armv7h')
+url='https://notabug.org/guile-zlib/guile-zlib'
+license=('GPL3')
+depends=('guile' 'zlib')
+source=("${pkgname}-${pkgver}.tar.gz::https://notabug.org/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('f1100be6dd31b02983cf498155bf11155ca833421f99698f29e5694317335fb1')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}