summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-07-18 23:48:45 -0500
committerLuis Martinez2021-07-18 23:48:45 -0500
commit7f65f8b9e98cae1f06bff5551ca9fad5551e9b1a (patch)
treeb1e75098d75fd60bd0b63f1ef4142afc62c35dc7
parent8415d33f5a241392e763d7b93bca424c98b8feab (diff)
downloadaur-7f65f8b9e98cae1f06bff5551ca9fad5551e9b1a.tar.gz
update to 3.0.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
2 files changed, 32 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27bf485225a..f6183cf9239c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = guile3
pkgdesc = Portable, embeddable Scheme implementation written in C
- pkgver = 3.0.5
+ pkgver = 3.0.7
pkgrel = 1
url = https://www.gnu.org/software/guile/
arch = x86_64
+ arch = pentium4
license = GPL3
depends = gmp
depends = libltdl
@@ -14,13 +15,12 @@ pkgbase = guile3
depends = libffi
depends = readline
options = !strip
- source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.5.tar.lz
- source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.5.tar.lz.sig
+ source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.7.tar.lz
+ source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.7.tar.lz.sig
source = skip-testing-oom-conditions.patch
validpgpkeys = 4FD4D288D445934E0A14F9A5A8803732E4436885
- sha256sums = a484eeffbd4d655b0c05b1382df8d40f1e561f7e71b963065762f6a6a497c675
+ sha256sums = f02166205ced31651d27bd037f947e199a442545ca73f913907c69469ddd7b54
sha256sums = SKIP
sha256sums = 2b053f0dafc5c68cc7f186c6252348e92e4b1e0f691e1e6eca7a5101c9b9f78a
pkgname = guile3
-
diff --git a/PKGBUILD b/PKGBUILD
index 1149d65e49f6..627438497e3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Rose Kunkel <rose at rosekunkel dot me>
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Contributor: Rose Kunkel <rose at rosekunkel dot me>
pkgname=guile3
-_pkgname=guile
-pkgver=3.0.5
+pkgver=3.0.7
pkgrel=1
pkgdesc='Portable, embeddable Scheme implementation written in C'
-arch=('x86_64')
+arch=('x86_64' 'pentium4')
url='https://www.gnu.org/software/guile/'
license=('GPL3')
depends=('gmp' 'libltdl' 'ncurses' 'texinfo' 'libunistring' 'gc' 'libffi' 'readline')
-source=("https://ftp.gnu.org/pub/gnu/${_pkgname}/${_pkgname}-$pkgver.tar.lz"{,.sig}
+source=("https://ftp.gnu.org/pub/gnu/guile/guile-$pkgver.tar.lz"{,.sig}
'skip-testing-oom-conditions.patch')
-sha256sums=('a484eeffbd4d655b0c05b1382df8d40f1e561f7e71b963065762f6a6a497c675'
+sha256sums=('f02166205ced31651d27bd037f947e199a442545ca73f913907c69469ddd7b54'
'SKIP'
'2b053f0dafc5c68cc7f186c6252348e92e4b1e0f691e1e6eca7a5101c9b9f78a')
validpgpkeys=('4FD4D288D445934E0A14F9A5A8803732E4436885') # Andy Wingo
@@ -20,33 +20,35 @@ validpgpkeys=('4FD4D288D445934E0A14F9A5A8803732E4436885') # Andy Wingo
# See https://aur.archlinux.org/packages/guile3/#comment-769796
options=('!strip')
-function prepare {
+prepare() {
# Disable a test that's known to fail. See
# https://lists.gnu.org/archive/html/bug-guile/2021-01/msg00001.html
- patch -p1 -d "${_pkgname}-$pkgver" <skip-testing-oom-conditions.patch
+ if [[ "$CARCH" == 'pentium4' || "$CARCH" == 'i686' ]]; then
+ patch -p1 -d "guile-$pkgver" < skip-testing-oom-conditions.patch
+ fi
}
-function build {
- cd "${_pkgname}-$pkgver"
+build() {
+ cd "guile-$pkgver"
- # Install guile as guile3 and info files to /usr/share/info/guile3 so we don't
- # conflict with the official guile package.
- ./configure \
- --prefix=/usr \
- --infodir=/usr/share/info/${pkgname} \
- --program-suffix=3
- make
+ # Install guile as guile3 and info files to /usr/share/info/guile3 so we don't
+ # conflict with the official guile package.
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info/${pkgname} \
+ --program-suffix=3
+ make
}
-function check {
- cd "${_pkgname}-$pkgver"
- make -k check
+check() {
+ cd "guile-$pkgver"
+ make -k check
}
-function package {
- cd "${_pkgname}-$pkgver"
- make DESTDIR="$pkgdir/" install
+package() {
+ cd "guile-$pkgver"
+ make DESTDIR="$pkgdir/" install
- # The official guile package already provides this file.
- rm "$pkgdir"/usr/share/aclocal/guile.m4
+ # The official guile package already provides this file.
+ rm "$pkgdir"/usr/share/aclocal/guile.m4
}