summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRose Kunkel2021-01-09 23:51:06 -0800
committerRose Kunkel2021-01-09 23:51:06 -0800
commit8415d33f5a241392e763d7b93bca424c98b8feab (patch)
tree81844349f9a913e607ce4b3a11716c8c7e9e7631
parent4dfabfda464d98bc68373bfdbe6dd5c108acf70b (diff)
downloadaur-8415d33f5a241392e763d7b93bca424c98b8feab.tar.gz
Update to version 3.0.5 and remove conflict with official guile package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
-rw-r--r--skip-testing-oom-conditions.patch28
3 files changed, 63 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ab8a2bc19f1..a27bf485225a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = guile3
pkgdesc = Portable, embeddable Scheme implementation written in C
- pkgver = 3.0.4
+ pkgver = 3.0.5
pkgrel = 1
url = https://www.gnu.org/software/guile/
arch = x86_64
@@ -13,13 +13,14 @@ pkgbase = guile3
depends = gc
depends = libffi
depends = readline
- provides = guile
- conflicts = guile
- source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.4.tar.lz
- source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.4.tar.lz.sig
- validpgpkeys = 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
- sha256sums = f2b0b66fd72bc24df76856e1549bf327c025b8a5d5fa3cb1696327c5941c89c4
+ options = !strip
+ source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.5.tar.lz
+ source = https://ftp.gnu.org/pub/gnu/guile/guile-3.0.5.tar.lz.sig
+ source = skip-testing-oom-conditions.patch
+ validpgpkeys = 4FD4D288D445934E0A14F9A5A8803732E4436885
+ sha256sums = a484eeffbd4d655b0c05b1382df8d40f1e561f7e71b963065762f6a6a497c675
sha256sums = SKIP
+ sha256sums = 2b053f0dafc5c68cc7f186c6252348e92e4b1e0f691e1e6eca7a5101c9b9f78a
pkgname = guile3
diff --git a/PKGBUILD b/PKGBUILD
index 586f434a5383..1149d65e49f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,39 @@
pkgname=guile3
_pkgname=guile
-pkgver=3.0.4
+pkgver=3.0.5
pkgrel=1
pkgdesc='Portable, embeddable Scheme implementation written in C'
arch=('x86_64')
url='https://www.gnu.org/software/guile/'
license=('GPL3')
depends=('gmp' 'libltdl' 'ncurses' 'texinfo' 'libunistring' 'gc' 'libffi' 'readline')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("https://ftp.gnu.org/pub/gnu/${_pkgname}/${_pkgname}-$pkgver.tar.lz"{,.sig})
-sha256sums=('f2b0b66fd72bc24df76856e1549bf327c025b8a5d5fa3cb1696327c5941c89c4'
- 'SKIP')
-validpgpkeys=('3CE464558A84FDC69DB40CFB090B11993D9AEBB5') # Ludovic Courtès
+source=("https://ftp.gnu.org/pub/gnu/${_pkgname}/${_pkgname}-$pkgver.tar.lz"{,.sig}
+ 'skip-testing-oom-conditions.patch')
+sha256sums=('a484eeffbd4d655b0c05b1382df8d40f1e561f7e71b963065762f6a6a497c675'
+ 'SKIP'
+ '2b053f0dafc5c68cc7f186c6252348e92e4b1e0f691e1e6eca7a5101c9b9f78a')
+validpgpkeys=('4FD4D288D445934E0A14F9A5A8803732E4436885') # Andy Wingo
+
+# Running strip can potentially mangle Guile bytecode (.go) files.
+# See https://aur.archlinux.org/packages/guile3/#comment-769796
+options=('!strip')
+
+function prepare {
+ # Disable a test that's known to fail. See
+ # https://lists.gnu.org/archive/html/bug-guile/2021-01/msg00001.html
+ patch -p1 -d "${_pkgname}-$pkgver" <skip-testing-oom-conditions.patch
+}
function build {
cd "${_pkgname}-$pkgver"
- ./configure --prefix=/usr
+
+ # Install guile as guile3 and info files to /usr/share/info/guile3 so we don't
+ # conflict with the official guile package.
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info/${pkgname} \
+ --program-suffix=3
make
}
@@ -30,4 +46,7 @@ function check {
function package {
cd "${_pkgname}-$pkgver"
make DESTDIR="$pkgdir/" install
+
+ # The official guile package already provides this file.
+ rm "$pkgdir"/usr/share/aclocal/guile.m4
}
diff --git a/skip-testing-oom-conditions.patch b/skip-testing-oom-conditions.patch
new file mode 100644
index 000000000000..9fbe2f402c11
--- /dev/null
+++ b/skip-testing-oom-conditions.patch
@@ -0,0 +1,28 @@
+From 8fc748b3be138fcd86bedb9129e161deacda1154 Mon Sep 17 00:00:00 2001
+From: Rose Kunkel <rose@rosekunkel.me>
+Date: Sat, 9 Jan 2021 17:51:36 -0800
+Subject: [PATCH] Skip testing OOM conditions
+
+---
+ test-suite/standalone/test-out-of-memory | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/test-suite/standalone/test-out-of-memory b/test-suite/standalone/test-out-of-memory
+index 31375a559..bc0df3286 100755
+--- a/test-suite/standalone/test-out-of-memory
++++ b/test-suite/standalone/test-out-of-memory
+@@ -3,6 +3,11 @@ guild compile "$0"
+ exec guile -q -s "$0" "$@"
+ !#
+
++;; Skip this test unconditionally. See
++;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=42026
++;; https://aur.archlinux.org/packages/guile3/#comment-785252
++(exit 77)
++
+ (unless (defined? 'setrlimit)
+ ;; Without an rlimit, this test can take down your system, as it
+ ;; consumes all of your memory. That doesn't seem like something we
+--
+2.30.0
+