summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-09-03 16:04:40 -0600
committeryochananmarqos2019-09-03 16:04:40 -0600
commit55f28e68426c750fdf370d42feb19254da03e5b1 (patch)
tree74c589c058c96cb8644d7e5dd50338c7dc70bfb2
downloadaur-55f28e68426c750fdf370d42feb19254da03e5b1.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD34
-rw-r--r--guiscrcpy.desktop9
-rw-r--r--guiscrcpy.sh2
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e6dd73fa291
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = guiscrcpy-git
+ pkgdesc = A full fledged GUI integration for the most award winning open-source Android screen mirroring system -- scrcpy
+ pkgver = 1.10.r53.897316e
+ pkgrel = 1
+ url = https://srevinsaju.github.io/guiscrcpy
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = scrcpy
+ depends = python-pyqt5
+ depends = python-psutil
+ optdepends = python-qdarkstyle: for dark theme
+ optdepends = wmctrl: to use development toolkit
+ optdepends = xdotool: to use development toolkit
+ provides = guiscrcpy
+ conflicts = guiscrcpy
+ source = git+https://github.com/srevinsaju/guiscrcpy.git
+ source = guiscrcpy.desktop
+ source = guiscrcpy.sh
+ sha256sums = SKIP
+ sha256sums = 17d3182d5a910b51803c72922ffd5a226691a290e360b72a93597dc5700a4c96
+ sha256sums = 21a9e0f6a38db03cbe84d6498519bd79d66796f47cd6a738133f38a45ea4bb42
+
+pkgname = guiscrcpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0770f3dd83bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=guiscrcpy-git
+pkgver=1.10.r53.897316e
+pkgrel=1
+pkgdesc="A full fledged GUI integration for the most award winning open-source Android screen mirroring system -- scrcpy"
+arch=('i686' 'x86_64')
+url="https://srevinsaju.github.io/guiscrcpy"
+license=('GPL3')
+depends=('scrcpy' 'python-pyqt5' 'python-psutil')
+makedepends=('git')
+optdepends=('python-qdarkstyle: for dark theme'
+ 'wmctrl: to use development toolkit'
+ 'xdotool: to use development toolkit')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/srevinsaju/guiscrcpy.git'
+ 'guiscrcpy.desktop'
+ 'guiscrcpy.sh')
+sha256sums=('SKIP'
+ '17d3182d5a910b51803c72922ffd5a226691a290e360b72a93597dc5700a4c96'
+ '21a9e0f6a38db03cbe84d6498519bd79d66796f47cd6a738133f38a45ea4bb42')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/"{opt/${pkgname%-git},usr/bin}
+ cp -r * "$pkgdir/opt/${pkgname%-git}/"
+ install -Dm755 "$srcdir/${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+}
diff --git a/guiscrcpy.desktop b/guiscrcpy.desktop
new file mode 100644
index 000000000000..2c5242ac17a3
--- /dev/null
+++ b/guiscrcpy.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=guiscrcpy
+Comment=GUI for scrcpy
+Exec=python /opt/guiscrcpy/__main__.py
+Terminal=false
+Icon=/opt/guiscrcpy/ui/guiscrcpy_logo.svg
+Type=Application
+Categories=Utility
+StartupNotify=false
diff --git a/guiscrcpy.sh b/guiscrcpy.sh
new file mode 100644
index 000000000000..0aee4e60441d
--- /dev/null
+++ b/guiscrcpy.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+python /opt/guiscrcpy/__main__.py