summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGimmeapill2018-01-25 21:11:42 +0100
committerGimmeapill2018-01-25 21:11:42 +0100
commit2ff1d2e2f2f0615b0fc13aac6d606df19641007b (patch)
tree1427236451cee8c06ee5e2cc1219ad07b25188a9
parenta1d89ebef1e19a44b40d1bab5a39eb1419097314 (diff)
downloadaur-2ff1d2e2f2f0615b0fc13aac6d606df19641007b.tar.gz
more build flags tweaking
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01e5e18fdec9..aea1080a9c03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jan 22 23:12:49 UTC 2018
+# Thu Jan 25 20:11:21 UTC 2018
pkgbase = guitarix-git
pkgdesc = A virtual guitar amplifier for Linux
pkgver = 0.36.1.r16.g51ba3d2b
@@ -8,6 +8,7 @@ pkgbase = guitarix-git
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
makedepends = python
makedepends = python2
makedepends = boost
@@ -15,7 +16,6 @@ pkgbase = guitarix-git
makedepends = gperf
makedepends = intltool
makedepends = lv2
- depends = git
depends = jack
depends = gtkmm
depends = liblrdf
@@ -24,6 +24,7 @@ pkgbase = guitarix-git
depends = boost-libs
depends = zita-convolver
depends = zita-resampler
+ depends = ttf-roboto
optdepends = meterbridge: sound meters
provides = guitarix
provides = guitarix2
diff --git a/PKGBUILD b/PKGBUILD
index c9df9e42b606..80b758d2bc5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@ pkgdesc="A virtual guitar amplifier for Linux"
arch=('i686' 'x86_64')
url="http://guitarix.sourceforge.net"
license=('GPL')
-depends=('git' 'jack' 'gtkmm' 'liblrdf' 'lilv' 'bluez-libs' 'boost-libs' 'zita-convolver' 'zita-resampler')
+depends=('jack' 'gtkmm' 'liblrdf' 'lilv' 'bluez-libs' 'boost-libs' 'zita-convolver' 'zita-resampler' 'ttf-roboto')
#depends=(jack liblrdf gtkmm fftw bluez-libs ffmpeg lilv boost-libs)
-makedepends=('python' 'python2' 'boost' 'eigen' 'gperf' 'intltool' 'lv2')
+makedepends=('git' 'python' 'python2' 'boost' 'eigen' 'gperf' 'intltool' 'lv2')
optdepends=('meterbridge: sound meters')
provides=("${pkgname%-*}" "guitarix2" "gx_head")
conflicts=("${pkgname%-*}" "guitarix2" "gx_head")
@@ -27,10 +27,11 @@ pkgver() {
build() {
cd "${pkgname%-*}/trunk"
python2 waf configure --prefix=/usr \
- --cxxflags-release \
- --optimize \
+ --optimization \
--new-ladspa \
- --install-roboto-font
+ --no-ldconfig \
+ --no-desktop-update \
+ --no-font-cache-update
python2 waf build
}