summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-11 01:32:31 -0800
committerAndy Weidenbaum2016-01-11 01:32:31 -0800
commit4366fa7223c4dd20c67cb19302b454ee5189e61e (patch)
treec5e6ecb715f8fa9f796af608e78791d5c12c050b
downloadaur-4366fa7223c4dd20c67cb19302b454ee5189e61e.tar.gz
Initial import
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD69
-rw-r--r--guix.install16
3 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c43d64688cf7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Mon Jan 11 09:32:28 UTC 2016
+pkgbase = guix-git
+ pkgdesc = A purely functional package manager
+ pkgver = 20160111
+ pkgrel = 1
+ url = https://www.gnu.org/software/guix/
+ install = guix.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gettext
+ makedepends = git
+ makedepends = help2man
+ makedepends = m4
+ makedepends = make
+ makedepends = pkg-config
+ depends = bzip2
+ depends = glibc
+ depends = gnutls
+ depends = graphviz
+ depends = guile
+ depends = guile-json
+ depends = libgcrypt
+ depends = patch
+ depends = sqlite
+ depends = xz
+ optdepends = emacs: emacs interface
+ provides = guix
+ conflicts = guix
+ source = git://git.sv.gnu.org/guix.git
+ sha256sums = SKIP
+
+pkgname = guix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..524cd2abeb69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: lantw44 (at) gmail (dot) com
+
+pkgname=guix-git
+pkgver=20160111
+pkgrel=1
+pkgdesc="A purely functional package manager"
+arch=('i686' 'x86_64')
+depends=('bzip2'
+ 'glibc'
+ 'gnutls'
+ 'graphviz'
+ 'guile'
+ 'guile-json'
+ 'libgcrypt'
+ 'patch'
+ 'sqlite'
+ 'xz')
+makedepends=('autoconf'
+ 'automake'
+ 'gettext'
+ 'git'
+ 'help2man'
+ 'm4'
+ 'make'
+ 'pkg-config')
+optdepends=('emacs: emacs interface')
+url="https://www.gnu.org/software/guix/"
+license=('GPL3')
+source=(git://git.sv.gnu.org/guix.git)
+sha256sums=('SKIP')
+provides=('guix')
+conflicts=('guix')
+install=guix.install
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ _compl_dir="$(pkg-config --variable=completionsdir bash-completion)"
+
+ msg2 'Building...'
+ ./bootstrap
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/guix \
+ --sysconfdir=/etc \
+ --sharedstatedir=/usr/share/guix \
+ --localstatedir=/var/lib/guix \
+ --with-bash-completion-dir="$_compl_dir" \
+ --disable-rpath \
+ --with-gnu-ld
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}
diff --git a/guix.install b/guix.install
new file mode 100644
index 000000000000..5eb2b01ffc6a
--- /dev/null
+++ b/guix.install
@@ -0,0 +1,16 @@
+infodir=usr/share/info
+file=guix.info
+
+post_install() {
+ [[ -x usr/bin/install-info ]] || return 0
+ install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ install-info --delete "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+}