summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2019-06-18 09:58:40 +0300
committerNikolay Korotkiy2019-06-18 09:58:40 +0300
commit64b5d94310e95f097038c028c24bd156373e90a5 (patch)
tree56a464c5287a86c2e9f192ff973c17000c178843
parent495eda9e6c6e52d035f6287a23e30b161f5fd82c (diff)
downloadaur-64b5d94310e95f097038c028c24bd156373e90a5.tar.gz
various fixes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78d8dc0802d8..dee34699fb12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 5.1.3
-# Mon Jun 17 21:25:35 UTC 2019
+# Tue Jun 18 06:56:36 UTC 2019
pkgbase = guix-git
pkgdesc = A purely functional package manager
- pkgver = v1.0.1.r840.gc8535731b8
+ pkgver = 1.0.1.r856.g1e609b78c7
pkgrel = 1
url = https://www.gnu.org/software/guix/
install = guix.install
@@ -35,7 +35,7 @@ pkgbase = guix-git
optdepends = fish: completions
optdepends = emacs: emacs interface
optdepends = guile-ssh: to offload builds to other machines
- provides = guix
+ provides = guix=1.0.1.r856.g1e609b78c7
conflicts = guix
source = git://git.sv.gnu.org/guix.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9a21b8fae7eb..f7181fe68279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,14 @@
# Contributor: Joe Hillenbrand <joehillen@gmail.com>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
# Contributor: lantw44 (at) gmail (dot) com
-
-pkgname=guix-git
-pkgver=v1.0.1.r840.gc8535731b8
+_pkgname=guix
+pkgname=${_pkgname}-git
+pkgver=1.0.1.r856.g1e609b78c7
pkgrel=1
pkgdesc="A purely functional package manager"
arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/guix/"
+license=('GPL3')
depends=(
'bzip2'
'glibc'
@@ -37,24 +39,22 @@ optdepends=(
'fish: completions'
'emacs: emacs interface'
'guile-ssh: to offload builds to other machines')
-url="https://www.gnu.org/software/guix/"
-license=('GPL3')
-source=(git://git.sv.gnu.org/guix.git)
+provides=("${_pkgname}=${pkgver}")
+conflicts=(${_pkgname})
+source=("git://git.sv.gnu.org/${_pkgname}.git")
sha256sums=('SKIP')
-provides=('guix')
-conflicts=('guix')
-install=guix.install
+install="${_pkgname}.install"
pkgver() {
- cd ${pkgname%-git}
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd ${_pkgname}
+ git describe --long | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${pkgname%-git}
+ cd ${_pkgname}
- _bash_compl="--with-bash-completion-dir=\"$(pkg-config --variable=completionsdir bash-completion)\"" || _bash_compl=""
- _fish_compl="--with-fish-completion-dir=\"$(pkg-config --variable=completionsdir fish)\"" || _fish_compl=""
+ local bash_completion_dir="$(pkg-config --variable=completionsdir bash-completion)"
+ local fish_completion_dir="$(pkg-config --variable=completionsdir fish)"
msg2 'Building...'
./bootstrap
@@ -65,15 +65,15 @@ build() {
--sysconfdir=/etc \
--sharedstatedir=/usr/share/guix \
--localstatedir=/var \
- $_bash_compl \
- $_fish_compl \
+ --with-bash-completion-dir="${bash_completion_dir}" \
+ --with-fish-completion-dir="${fish_completion_dir}" \
--disable-rpath \
--with-gnu-ld
make
}
package() {
- cd ${pkgname%-git}
+ cd ${_pkgname}
make DESTDIR="${pkgdir}" install