summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-03-05 14:26:14 +0000
committerMilk Brewster2020-03-05 14:26:14 +0000
commit6f9bf3411f5ceb4ba2e3b6ce9f4cebf2155229b9 (patch)
tree3dee3ff62d43d871786602ccc0008fb0ba24dd5b
downloadaur-6f9bf3411f5ceb4ba2e3b6ce9f4cebf2155229b9.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a4912c30f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gula-plugins-git
+ pkgdesc = https://github.com/steveb/gula-plugins
+ pkgver = r45.fbc3c1a
+ pkgrel = 1
+ url = https://github.com/steveb/gula-plugins
+ arch = x86_64
+ groups = lv2-plugins
+ license = GPL
+ depends = lv2
+ source = git+https://github.com/steveb/gula-plugins
+ md5sums = SKIP
+
+pkgname = gula-plugins-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1994dad6589b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+pkgname=gula-plugins-git
+pkgdesc="https://github.com/steveb/gula-plugins"
+pkgver=r45.fbc3c1a
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/steveb/gula-plugins"
+license=(GPL)
+groups=(lv2-plugins)
+depends=('lv2')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/steveb/gula-plugins")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd gula-plugins
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd gula-plugins
+}
+
+build() {
+ cd gula-plugins
+ # ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd gula-plugins
+ mkdir -p "$pkgdir"/usr/lib/lv2
+ cp -r lv2/* "$pkgdir/usr/lib/lv2"
+}