summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2019-07-30 16:16:23 +0200
committerLubosz Sarnecki2019-07-30 17:28:24 +0200
commit79f11bb7037b05cce5730ccf42080bfcc07ebaa8 (patch)
tree0a812b4113e7d2a71f2aa1cad1ca3ff7bd538bc7
downloadaur-79f11bb7037b05cce5730ccf42080bfcc07ebaa8.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b89cb416b56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Tue Jul 30 15:27:54 UTC 2019
+pkgbase = gulkan-git
+ pkgdesc = A GLib library for Vulkan abstraction.
+ pkgver = 0.12.1.112.bacb152
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xrdesktop/gulkan
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ makedepends = glslang
+ makedepends = vulkan-headers
+ makedepends = gtk-doc
+ depends = glib2
+ depends = gdk-pixbuf2
+ depends = vulkan-icd-loader
+ depends = graphene
+ depends = cairo
+ provides = gulkan=0.12.1.112.bacb152
+ conflicts = gulkan
+ options = debug
+ options = !strip
+ source = git+https://gitlab.freedesktop.org/xrdesktop/gulkan.git
+ md5sums = SKIP
+
+pkgname = gulkan-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..061c08c98be3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Lubosz Sarnecki <lubosz.sarnecki@collabora.com>
+
+_realname='gulkan'
+pkgname="$_realname-git"
+pkgver=0.12.1.112.bacb152
+pkgrel=1
+pkgdesc='A GLib library for Vulkan abstraction.'
+arch=('i686' 'x86_64')
+url='https://gitlab.freedesktop.org/xrdesktop/gulkan'
+depends=('glib2' 'gdk-pixbuf2' 'vulkan-icd-loader' 'graphene' 'cairo')
+provides=("$_realname="$pkgver)
+conflicts=("$_realname")
+makedepends=('meson' 'git' 'glslang' 'vulkan-headers' 'gtk-doc')
+license=('MIT')
+options=('debug' '!strip')
+
+source=('git+https://gitlab.freedesktop.org/xrdesktop/gulkan.git')
+md5sums=('SKIP')
+
+ver() {
+ PREFIX="project('gulkan', 'c', version: '"
+ echo $(grep "$PREFIX" meson.build | sed -e "s/${PREFIX}//" | sed "s/',//")
+}
+
+pkgver() {
+ cd $_realname
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $(ver).$revision.$hash
+}
+
+build() {
+ cd $_realname
+ rm -rf build
+ meson build --prefix=/usr/ --libdir=lib
+ ninja -C build
+}
+
+#check() {
+# cd $_realname
+# ninja -C build test
+#}
+
+package() {
+ cd $_realname
+ DESTDIR="$pkgdir" ninja -C build install
+}