summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-06-06 09:37:27 +0200
committerPhilipp A2017-06-06 09:37:27 +0200
commit4fc19dda4bb88add92a3edce68d94e0f2d5ee00c (patch)
tree10eddef21d6848806fb525ca9250703b292a6aba
parent97ce5389aa367dd4a10278b7934a7a33c315f015 (diff)
downloadaur-4fc19dda4bb88add92a3edce68d94e0f2d5ee00c.tar.gz
fixed linking
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ce76f1b52d8..cd4ecabe3f15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Jun 2 15:00:36 UTC 2017
pkgbase = gulp-cli
pkgdesc = The streaming build system
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = http://gulpjs.com/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index c575d4b623be..67e80db0241d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gulp-cli
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc='The streaming build system'
arch=(any)
url='http://gulpjs.com/'
@@ -26,16 +26,18 @@ build() {
package() {
cd "$srcdir/package"
- install -d "$pkgdir/usr/lib/node_modules/gulp-cli"
- for f in bin lib node_modules CHANGELOG.md index.js package.json README.md; do
- cp -rt "$pkgdir/usr/lib/node_modules/gulp-cli" "$f"
+ install -Dm755 'bin/gulp.js' "$pkgdir/usr/lib/node_modules/gulp-cli/bin/gulp.js"
+ for f in CHANGELOG.md index.js package.json README.md; do
+ install -Dm644 "$f" "$pkgdir/usr/lib/node_modules/gulp-cli/$f"
+ done
+ for d in lib node_modules; do
+ find "$d" -type f -exec install -Dm644 {} "$pkgdir/usr/lib/node_modules/gulp-cli/{}" \;
done
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 gulp.1 "$pkgdir/usr/share/man/man1/gulp.1"
install -d "$pkgdir/usr/bin"
- chmod 755 "$pkgdir/usr/lib/node_modules/gulp-cli/bin/gulp.js"
- ln -s "$pkgdir/usr/lib/node_modules/gulp-cli/bin/gulp.js" "$pkgdir/usr/bin/gulp"
+ ln -s '/usr/lib/node_modules/gulp-cli/bin/gulp.js' "$pkgdir/usr/bin/gulp"
install -Dm644 completion/bash "$pkgdir/usr/share/bash-completion/completions/gulp"
install -Dm644 completion/fish "$pkgdir/usr/share/fish/completions/gulp.fish"