summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThat One Seong2024-02-27 19:03:30 -0500
committerThat One Seong2024-02-27 19:03:30 -0500
commit1ceb8e14544808d09d49e01d71bebc0fca2d0bb9 (patch)
tree14e8693ce1c55c0049b72cacc41b442f98c8373f
parent5780cf3e1374b9867f06ed280d491a2324fcc6de (diff)
downloadaur-1ceb8e14544808d09d49e01d71bebc0fca2d0bb9.tar.gz
Added desktop launcher.
-rw-r--r--.SRCINFO4
-rw-r--r--GUN4ALL-GUI.desktop8
-rw-r--r--PKGBUILD9
3 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f92679754e8..4da45873e69d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gun4all-gui
pkgdesc = Configuration utility for the IR-GUN4ALL DIY light-gun system.
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SeongGino/GUN4ALL-GUI
install = gun4all-gui.install
arch = x86_64
@@ -13,6 +13,8 @@ pkgbase = gun4all-gui
depends = qt5-svg
depends = icu
source = https://github.com/SeongGino/GUN4ALL-GUI/archive/refs/tags/v1.0-1.tar.gz
+ source = GUN4ALL-GUI.desktop
md5sums = b04ee547698bd518ad30d1273a104a06
+ md5sums = 5a34660fff6347e05463589e51b90bec
pkgname = gun4all-gui
diff --git a/GUN4ALL-GUI.desktop b/GUN4ALL-GUI.desktop
new file mode 100644
index 000000000000..0fe8a606d3a9
--- /dev/null
+++ b/GUN4ALL-GUI.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Exec=G4A-GUI
+GenericName=Configuration utility for the GUN4ALL lightgun system
+Name=GUN4ALL-GUI
+NoDisplay=false
+StartupNotify=true
+Terminal=false
+Type=Application
diff --git a/PKGBUILD b/PKGBUILD
index 12010f8976a4..c13d530d71f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=GUN4ALL-GUI
pkgname=gun4all-gui
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Configuration utility for the IR-GUN4ALL DIY light-gun system.'
arch=('x86_64' 'aarch64')
url='https://github.com/SeongGino/GUN4ALL-GUI'
@@ -11,9 +11,11 @@ license=('GPL-3.0-only')
depends=('qt5-base' 'qt5-serialport' 'qt5-svg' 'icu')
makedepends=('cmake')
install=$pkgname.install
-source=("https://github.com/SeongGino/GUN4ALL-GUI/archive/refs/tags/v${pkgver}-1.tar.gz")
+source=("https://github.com/SeongGino/GUN4ALL-GUI/archive/refs/tags/v${pkgver}-1.tar.gz"
+ 'GUN4ALL-GUI.desktop')
# TODO: -1 is a minor release
-md5sums=('b04ee547698bd518ad30d1273a104a06')
+md5sums=('b04ee547698bd518ad30d1273a104a06'
+ '5a34660fff6347e05463589e51b90bec')
build() {
mkdir "$srcdir/$_name-$pkgver-1/build"
@@ -24,4 +26,5 @@ build() {
package() {
install -Dm755 "$srcdir/$_name-$pkgver-1/build/G4A-GUImain" "$pkgdir/usr/bin/G4A-GUI"
+ desktop-file-install "$srcdir/GUN4ALL-GUI.desktop" --dir="$pkgdir/usr/share/applications"
}