summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichiru Saito2018-07-22 00:30:27 +0900
committerMichiru Saito2018-07-22 00:30:27 +0900
commitad282fcba5d699c0ba1fe36db0fdae48c9ab99c7 (patch)
tree7c99131c599dfba6bc416d5dceefb9cf08ce50b7
downloadaur-ad282fcba5d699c0ba1fe36db0fdae48c9ab99c7.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD32
-rw-r--r--gurashot.desktop9
-rw-r--r--gurashot.install11
-rw-r--r--gurashot.pngbin0 -> 2454 bytes
-rw-r--r--gurashot.sh2
6 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57f0d100a975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sat Jul 21 15:28:48 UTC 2018
+pkgbase = gurashot
+ pkgdesc = ID photo creation tool
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = http://app.gura-lang.org/gurashot/
+ install = gurashot.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = unzip
+ depends = gura
+ depends = desktop-file-utils
+ noextract = gurashot-1.4.3.zip
+ source = https://github.com/gura-app/gurashot/releases/download/v1.4.3/gurashot-1.4.3.zip
+ source = gurashot.sh
+ source = gurashot.png
+ source = gurashot.desktop
+ md5sums = b46f2db07106ddf8e153ddc5773b8058
+ md5sums = 533a162f0d6018dec234db19cb1663a4
+ md5sums = 8ca0a8703eeb5c85171502028668974a
+ md5sums = e7ad0893e4ccc2edd4d2679ed025c91e
+
+pkgname = gurashot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..135bdd3ed46e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Michiru Saito <urihcim at gmail dot com>
+pkgname=gurashot
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="ID photo creation tool"
+arch=('i686' 'x86_64')
+url='http://app.gura-lang.org/gurashot/'
+license=('unknown')
+install=$pkgname.install
+depends=('gura' 'desktop-file-utils')
+makedepends=('unzip')
+source=("https://github.com/gura-app/gurashot/releases/download/v${pkgver}/${pkgname}-${pkgver}.zip"
+ "${pkgname}.sh"
+ "${pkgname}.png"
+ "${pkgname}.desktop")
+noextract=("${pkgname}-${pkgver}.zip")
+md5sums=('b46f2db07106ddf8e153ddc5773b8058'
+ '533a162f0d6018dec234db19cb1663a4'
+ '8ca0a8703eeb5c85171502028668974a'
+ 'e7ad0893e4ccc2edd4d2679ed025c91e')
+
+prepare() {
+ sed -e "s/%PKGVER%/${pkgver}/" "${pkgname}.sh" > "${pkgname}"
+}
+
+package() {
+ install -d "${pkgdir}/usr/share"
+ unzip -o "${pkgname}-${pkgver}.zip" -d "${pkgdir}/usr/share" || true
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/gurashot.desktop b/gurashot.desktop
new file mode 100644
index 000000000000..07704c7b0e86
--- /dev/null
+++ b/gurashot.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Gura Shot
+Comment=ID photo creation tool
+Exec=gurashot
+Icon=gurashot
+Terminal=false
+Categories=Graphics
diff --git a/gurashot.install b/gurashot.install
new file mode 100644
index 000000000000..e202a5d0740e
--- /dev/null
+++ b/gurashot.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q /usr/share/applications
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/gurashot.png b/gurashot.png
new file mode 100644
index 000000000000..8e1ff84ec5f0
--- /dev/null
+++ b/gurashot.png
Binary files differ
diff --git a/gurashot.sh b/gurashot.sh
new file mode 100644
index 000000000000..821db4111ffe
--- /dev/null
+++ b/gurashot.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+gura /usr/share/gurashot-%PKGVER%/gurashot.guraw &