summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstefexec2025-03-04 22:47:50 +0100
committerstefexec2025-03-04 22:47:50 +0100
commita249bc7748b74c8d8590dab457eca2715035dea6 (patch)
tree8d2b6dcf70d5a26bafb145ad02d657141dbb538b
downloadaur-a249bc7748b74c8d8590dab457eca2715035dea6.tar.gz
creating initial AUR package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5026e892f8fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gurkpad
+ pkgdesc = Lightweight text editor written in C.
+ pkgver = v0.1.0
+ pkgrel = 1
+ url = https://github.com/stefexec/gurkpad
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = gpad
+ conflicts = gpad
+ source = git+https://github.com/stefexec/gurkpad.git#tag=9dde75c357a818826665ec1b06ef12d0ac50fbeb
+ sha256sums = SKIP
+
+pkgname = gurkpad
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acbeefde36a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gurkenwerfer <stefan@gurk.dev>
+pkgname='gurkpad'
+pkgver=v0.1.0
+pkgrel=1
+pkgdesc="Lightweight text editor written in C."
+arch=('x86_64')
+url="https://github.com/stefexec/gurkpad"
+license=('GPL')
+makedepends=('git')
+provides=('gpad')
+conflicts=('gpad')
+_tag=9dde75c357a818826665ec1b06ef12d0ac50fbeb
+source=("git+https://github.com/stefexec/gurkpad.git#tag=$_tag")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 gurkpad "$pkgdir/usr/bin/gpad"
+}