summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hebb2013-04-10 03:39:22 -0400
committerThomas Hebb2013-04-10 03:39:22 -0400
commit7311dbd1f28f59694f1f08e84cc45be7674cde52 (patch)
treef1431d2cd67d9cb8293ced870142651f384d68b0
parente695510e16f73e534f985ef36054e2145d79d42a (diff)
downloadaur-7311dbd1f28f59694f1f08e84cc45be7674cde52.tar.gz
Fix aclocal errors
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
-rw-r--r--buildfix.patch22
-rw-r--r--configure_ac.patch32
4 files changed, 66 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8040dfa61d5..bce6e4ba72d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = gutenprint-cvs
- pkgdesc = Top quality printer drivers for POSIX systems
- pkgver = 20120525
+ pkgdesc = Top quality printer drivers for POSIX systems (cvs version)
+ pkgver = 20130410
pkgrel = 1
url = http://gimp-print.sourceforge.net/
install = gutenprint.install
arch = i686
arch = x86_64
license = GPL
- makedepends = gimp>=2.6.11
- makedepends = gtk2>=2.24.4
- makedepends = cups>=1.4.6
+ makedepends = gimp
+ makedepends = gtk2
+ makedepends = cups
makedepends = foomatic-db-engine
- makedepends = ghostscript>=9.02
- makedepends = cvs
- depends = readline
- depends = gnutls>=2.12.3
+ makedepends = ghostscript
+ depends = glibc
optdepends = cups: to use cups printer spooler(recommended)
optdepends = foomatic-db-engine: to use foomatic spooler
optdepends = ghostscript: adds postscript support for ijsgutenprint
@@ -22,13 +20,13 @@ pkgbase = gutenprint-cvs
provides = gutenprint
conflicts = gutenprint
replaces = gimp-print
- noextract = gutenprint-5.2.7.tar.bz2
+ noextract = gutenprint-5.2.9.tar.bz2
options = !libtool
options = !emptydirs
- source = http://downloads.sourceforge.net/gimp-print/gutenprint-5.2.7.tar.bz2
- source = buildfix.patch
- md5sums = b19029972bf28f6efd693270daf8f5de
- md5sums = 2354cdecf1fbab32eca84266c8c72e7d
+ source = http://downloads.sourceforge.net/gimp-print/gutenprint-5.2.9.tar.bz2
+ source = configure_ac.patch
+ sha256sums = 4b27e4f06f32d30271df89ecb6089bb11bcf2caec5f60b0909e083095354bca0
+ sha256sums = 041690da1d414e82297fc9bb8a1395cf133e198123c73572c69d932173343768
pkgname = gutenprint-cvs
diff --git a/PKGBUILD b/PKGBUILD
index e3996bb13867..684ee04f2074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,30 @@
# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgname=gutenprint-cvs
-pkgver=20120525
+_docname=gutenprint
+pkgver=20130410
+_docver='5.2.9'
pkgrel=1
-pkgdesc="Top quality printer drivers for POSIX systems"
+pkgdesc="Top quality printer drivers for POSIX systems (cvs version)"
arch=('i686' 'x86_64')
license=('GPL')
install=gutenprint.install
-depends=('readline' 'gnutls>=2.12.3') # needs to be checked. build log says -Lgnutls but namcap doesn't detect it
-makedepends=('gimp>=2.6.11' 'gtk2>=2.24.4' 'cups>=1.4.6' 'foomatic-db-engine' 'ghostscript>=9.02' 'cvs')
+depends=('glibc')
+makedepends=('gimp' 'gtk2' 'cups' 'foomatic-db-engine' 'ghostscript')
optdepends=('cups: to use cups printer spooler(recommended)'
'foomatic-db-engine: to use foomatic spooler'
'ghostscript: adds postscript support for ijsgutenprint'
'gimp: adds gutenprint plugin to gimp')
-source=('http://downloads.sourceforge.net/gimp-print/gutenprint-5.2.7.tar.bz2' 'buildfix.patch')
+source=("http://downloads.sourceforge.net/gimp-print/${_docname}-${_docver}.tar.bz2"
+ 'configure_ac.patch');
url='http://gimp-print.sourceforge.net/'
provides=('gutenprint')
conflicts=('gutenprint')
replaces=('gimp-print')
options=('!libtool' '!emptydirs')
-noextract=('gutenprint-5.2.7.tar.bz2')
-md5sums=('b19029972bf28f6efd693270daf8f5de'
- '2354cdecf1fbab32eca84266c8c72e7d')
+noextract=("${_docname}-${_docver}.tar.bz2")
+sha256sums=('4b27e4f06f32d30271df89ecb6089bb11bcf2caec5f60b0909e083095354bca0'
+ '041690da1d414e82297fc9bb8a1395cf133e198123c73572c69d932173343768')
_cvsroot=':pserver:anonymous:@gimp-print.cvs.sourceforge.net:/cvsroot/gimp-print'
_cvsmod='gimp-print'
@@ -46,17 +49,18 @@ build() {
cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
cd "$srcdir/$_cvsmod-build"
- patch -Np1 -i "${srcdir}/buildfix.patch"
+ patch -Np1 -i "${srcdir}/configure_ac.patch"
# We extract the precompiled documentation from the latest release because there is currently no easy way to run db2html on Arch.
- tar -xjf "${srcdir}/gutenprint-5.2.7.tar.bz2" --strip-components 1 'gutenprint-5.2.7/doc/developer'
- ./autogen.sh
- ./configure --prefix=/usr --disable-samples --with-cups --with-gimp2 \
- --disable-translated-cups-ppds --with-gimp2-as-gutenprint \
- --disable-libgutenprintui --enable-libgutenprintui2 --disable-gtktest \
- --enable-cups-ppds --enable-cups-ppds-at-top-level \
- --with-foomatic --with-foomatic3 --with-ghostscript \
- --disable-static --disable-static-genppd --with-ijs \
- --disable-globalized-cups-ppds
+ tar -xjf "${srcdir}/${_docname}-${_docver}.tar.bz2" --strip-components 1 "${_docname}-${_docver}/doc/developer"
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr \
+ --enable-samples \
+ --enable-cups-ppds \
+ --enable-cups-ppds-at-top-level \
+ --disable-translated-cups-ppds \
+ --disable-globalized-cups-ppds \
+ --disable-static \
+ --disable-static-genppd
make
}
diff --git a/buildfix.patch b/buildfix.patch
deleted file mode 100644
index 6b17a4029692..000000000000
--- a/buildfix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -up gutenprint-5.2.7/src/cups/commandtocanon.c.build gutenprint-5.2.7/src/cups/commandtocanon.c
---- gutenprint-5.2.7/src/cups/commandtocanon.c.build 2011-06-07 13:32:37.372042304 +0100
-+++ gutenprint-5.2.7/src/cups/commandtocanon.c 2011-06-07 13:32:41.270970750 +0100
-@@ -13,6 +13,7 @@
-
- #include <cups/cups.h>
- #include <ctype.h>
-+#include <stdio.h>
- #include <stdlib.h>
-
-
-diff -up gutenprint-5.2.7/src/cups/commandtoepson.c.build gutenprint-5.2.7/src/cups/commandtoepson.c
---- gutenprint-5.2.7/src/cups/commandtoepson.c.build 2007-12-24 17:19:20.000000000 +0000
-+++ gutenprint-5.2.7/src/cups/commandtoepson.c 2011-06-07 13:32:35.656073794 +0100
-@@ -30,6 +30,7 @@
-
- #include <cups/cups.h>
- #include <ctype.h>
-+#include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-
diff --git a/configure_ac.patch b/configure_ac.patch
new file mode 100644
index 000000000000..7386a168b1ee
--- /dev/null
+++ b/configure_ac.patch
@@ -0,0 +1,32 @@
+diff -ru gimp-print/configure.ac gimp-print.new/configure.ac
+--- gimp-print/configure.ac 2013-02-16 19:23:40.000000000 -0500
++++ gimp-print.new/configure.ac 2013-04-10 00:26:37.837341222 -0400
+@@ -140,7 +140,7 @@
+ GUTENPRINTUI2_LIBDEPS="${GUTENPRINTUI2_LIBDEPS} \$(GUTENPRINT_LIBS)"
+
+ dnl Specify a configuration file.
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+
+ dnl Available languages (translations)
+ ALL_LINGUAS="ca cs da de el en_GB es fi fr gl hu it ja nb nl pl pt ru sk sl sv uk zh_CN zh_TW"
+@@ -499,7 +499,6 @@
+ AC_ISC_POSIX
+ AC_PROG_AWK
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+diff -ru gimp-print/scripts/autogen.sh gimp-print.new/scripts/autogen.sh
+--- gimp-print/scripts/autogen.sh 2011-12-18 11:27:03.000000000 -0500
++++ gimp-print.new/scripts/autogen.sh 2013-04-10 00:26:27.894127709 -0400
+@@ -354,7 +354,7 @@
+ fi
+ echo "Running aclocal $aclocalinclude ..."
+ aclocal $aclocalinclude
+- if grep "^AM_CONFIG_HEADER" configure.ac >/dev/null; then
++ if grep "^AC_CONFIG_HEADERS" configure.ac >/dev/null; then
+ echo "Running autoheader..."
+ autoheader
+ fi