summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2016-01-15 00:02:50 +0100
committerBernhard Landauer2016-01-15 00:02:50 +0100
commit16cbac944112d41366fb2b34efdd72e6b6f77f8b (patch)
tree71c186c58863d6e4cb39f7809655d92ce54c958d
downloadaur-16cbac944112d41366fb2b34efdd72e6b6f77f8b.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD45
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6577dcc97ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Thu Jan 14 23:00:11 UTC 2016
+pkgbase = guvcview-qt5-git
+ pkgdesc = Video viewer and capturer for the linux uvc driver, Qt5-version
+ pkgver = 2.0.2.1.r33.g530f1e9
+ pkgrel = 1
+ url = http://guvcview.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = intltool
+ makedepends = qt5-tools
+ depends = ffmpeg
+ depends = gsl
+ depends = libpng
+ depends = libusb
+ depends = portaudio
+ depends = qt5-base
+ depends = sdl2
+ optdepends = pulseaudio: for PulseAudio support
+ provides = guvcview
+ conflicts = guvcview
+ source = guvcview-qt5-git::git://git.code.sf.net/p/guvcview/git-master
+ md5sums = SKIP
+
+pkgname = guvcview-qt5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55483015cd4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+# Maintainer: Tobias Frilling <tobias@frilling-online.de>
+
+pkgname=guvcview-qt5-git
+pkgver=2.0.2.1.r33.g530f1e9
+pkgrel=1
+pkgdesc="Video viewer and capturer for the linux uvc driver, Qt5-version"
+arch=('i686' 'x86_64')
+url="http://guvcview.sourceforge.net/"
+license=('GPL')
+depends=('ffmpeg'
+ 'gsl'
+ 'libpng'
+ 'libusb'
+ 'portaudio'
+ 'qt5-base'
+ 'sdl2')
+makedepends=('git'
+ 'intltool'
+ 'qt5-tools')
+optdepends=('pulseaudio: for PulseAudio support')
+provides=('guvcview')
+conflicts=('guvcview')
+source=("$pkgname::git://git.code.sf.net/p/guvcview/git-master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ export CPPFLAGS+=" -O2 "
+ ./bootstrap.sh --prefix=/usr
+ ./configure --disable-gtk3 --enable-qt5 --disable-debian-menu --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+