summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-06-30 14:34:30 +0200
committerPeter Mattern2016-06-30 14:42:23 +0200
commit0d5a2ebfd7b56e19bfb105cfa99d96e6dad05311 (patch)
tree130f2bb82ce0793dc38702ccc05d92bcad249d35
parent78ec10729d2f3d173accdacbef30f891a18143bf (diff)
downloadaur-0d5a2ebfd7b56e19bfb105cfa99d96e6dad05311.tar.gz
Use pacman hooks instead of install scriptlet
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
-rw-r--r--gvim-git.install12
3 files changed, 18 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c862a3eff7..6f710a3ba37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Thu Jun 30 12:42:14 UTC 2016
pkgbase = gvim-git
pkgdesc = Vim the editor. CLI version and GTK2 GUI providing majority of features.
- pkgver = 7.4.824
+ pkgver = 7.4.1967
pkgrel = 1
url = http://www.vim.org
- install = gvim-git.install
arch = i686
arch = x86_64
license = custom:vim
@@ -13,10 +14,8 @@ pkgbase = gvim-git
makedepends = python2
makedepends = ruby
depends = vim-runtime-git
+ depends = libxt
depends = gtk2
- depends = hicolor-icon-theme
- depends = gtk-update-icon-cache
- depends = desktop-file-utils
optdepends = lua: Lua interpreter
optdepends = perl: Perl interpreter
optdepends = python: Python 3 interpreter
@@ -24,10 +23,10 @@ pkgbase = gvim-git
optdepends = ruby: Ruby interpreter
provides = gvim
provides = xxd
+ conflicts = vim-minimal
conflicts = vim-minimal-git
conflicts = vim-git
- conflicts = vim-minimal
- conflicts = vim
+ conflicts = vim-git-git
conflicts = vim-python3
conflicts = gvim
conflicts = gvim-python3
diff --git a/PKGBUILD b/PKGBUILD
index 1430d0b805e..0bf94528d56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,22 @@
_pkgname=vim
pkgname="gvim-git"
-pkgver=7.4.824
+pkgver=7.4.1967
pkgrel=1
-pkgdesc="Vim the editor. CLI version and GTK2 GUI providing majority of features."
-arch=("i686" "x86_64")
-url="http://www.vim.org"
-license=("custom:vim")
-depends=("vim-runtime-git" "gtk2" "hicolor-icon-theme" "gtk-update-icon-cache" "desktop-file-utils")
-optdepends=("lua: Lua interpreter" "perl: Perl interpreter" "python: Python 3 interpreter"
- "python2: Python 2 interpreter" "ruby: Ruby interpreter")
-makedepends=("git" "lua" "python" "python2" "ruby")
-provides=("gvim" "xxd")
-conflicts=("vim-minimal-git" "vim-git"
- "vim-minimal" "vim" "vim-python3" "gvim" "gvim-python3")
-source=("git+https://github.com/vim/vim.git"
+pkgdesc='Vim the editor. CLI version and GTK2 GUI providing majority of features.'
+arch=('i686' 'x86_64')
+url='http://www.vim.org'
+license=('custom:vim')
+depends=('vim-runtime-git' 'libxt' 'gtk2')
+optdepends=('lua: Lua interpreter' 'perl: Perl interpreter' 'python: Python 3 interpreter'
+ 'python2: Python 2 interpreter' 'ruby: Ruby interpreter')
+makedepends=('git' 'lua' 'python' 'python2' 'ruby')
+provides=('gvim' 'xxd')
+conflicts=("vim-minimal"{,-git} "vim-git"{,-git} 'vim-python3' "gvim"{,-python3})
+source=("git+https://github.com/$_pkgname/$_pkgname.git"
"gvim.desktop")
sha256sums=("SKIP"
"97e94c3ca5825d6ab50096eb8449adf1b05c88ad13e60e6a99be8daacc797eac")
-install=gvim-git.install
pkgver() {
cd $_pkgname
diff --git a/gvim-git.install b/gvim-git.install
deleted file mode 100644
index f41381c2b1c..00000000000
--- a/gvim-git.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- gtk-update-icon-cache -f /usr/share/icons/hicolor
- update-desktop-database --quiet
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}